Bug 403126 - Ksysguard crashed when scrolling to the bottom then closing it
Summary: Ksysguard crashed when scrolling to the bottom then closing it
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.14.4
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-01-12 04:59 UTC by Buck Shockley
Modified: 2019-02-08 16:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buck Shockley 2019-01-12 04:59:02 UTC
Application: ksysguard (5.14.4)

Qt Version: 5.12.0
Frameworks Version: 5.53.0
Operating System: Linux 4.20.0-1-MANJARO x86_64
Distribution: "Manjaro Linux"

-- Information about the crash:
- What I was doing when the application crashed:
I had opened Ksysguard and scrolled to the bottom of the list to check if wineserver had been killed properly then tried to close it and I was alerted to a crash.

The crash does not seem to be reproducible.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fdf02ee4240 (LWP 23739))]

Thread 3 (Thread 0x7fdefb59c700 (LWP 23742)):
#0  0x00007fdf0e6b9c21 in poll () at /usr/lib/libc.so.6
#1  0x00007fdf08121540 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fdf0812162e in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fdf0cdf35c4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007fdf0cd9c58c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007fdf0cbe05c9 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007fdf0d104ba6 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007fdf0cbe19cc in  () at /usr/lib/libQt5Core.so.5
#8  0x00007fdf089eba9d in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007fdf0e6c4b23 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7fdf02edd700 (LWP 23740)):
#0  0x00007fdf089f1afc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007fdf0ca49cd1 in __gthread_cond_wait (__mutex=<optimized out>, __cond=<optimized out>) at /build/gcc/src/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu/bits/gthr-default.h:864
#2  0x00007fdf0ca49cd1 in std::condition_variable::wait(std::unique_lock<std::mutex>&) (this=<optimized out>, __lock=...) at /build/gcc/src/gcc/libstdc++-v3/src/c++11/condition_variable.cc:53
#3  0x00007fdf0b883f54 in  () at /usr/lib/libQt5WebKit.so.5
#4  0x00007fdf0b884079 in  () at /usr/lib/libQt5WebKit.so.5
#5  0x00007fdf0ca50063 in std::execute_native_thread_routine(void*) (__p=0x564a2e46ccb0) at /build/gcc/src/gcc/libstdc++-v3/src/c++11/thread.cc:80
#6  0x00007fdf089eba9d in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007fdf0e6c4b23 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7fdf02ee4240 (LWP 23739)):
[KCrash Handler]
#6  0x00007fdf0cc61326 in operator==(QString const&, QString const&) () at /usr/lib/libQt5Core.so.5
#7  0x00007fdf0d9c5138 in QLabel::setText(QString const&) () at /usr/lib/libQt5Widgets.so.5
#8  0x00007fdf0e7fde15 in  () at /usr/lib/libkdeinit5_ksysguard.so
#9  0x00007fdf0e4705b9 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/libksgrd.so.7
#10 0x00007fdf0e477cd0 in  () at /usr/lib/libksgrd.so.7
#11 0x00007fdf0cdc83e0 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#12 0x00007fdf0cd3106b in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /usr/lib/libQt5Core.so.5
#13 0x00007fdf0cd36cc4 in  () at /usr/lib/libQt5Core.so.5
#14 0x00007fdf0cd37120 in  () at /usr/lib/libQt5Core.so.5
#15 0x00007fdf0cdc828c in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#16 0x00007fdf0cdd3eea in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib/libQt5Core.so.5
#17 0x00007fdf0cdd4242 in QSocketNotifier::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#18 0x00007fdf0d892e34 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#19 0x00007fdf0d89a671 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#20 0x00007fdf0cd9d8f9 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#21 0x00007fdf0cdf4226 in  () at /usr/lib/libQt5Core.so.5
#22 0x00007fdf0811fa2f in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#23 0x00007fdf081215e9 in  () at /usr/lib/libglib-2.0.so.0
#24 0x00007fdf0812162e in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#25 0x00007fdf0cdf35a9 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#26 0x00007fdf0cd9c58c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#27 0x00007fdf0cda4896 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#28 0x00007fdf0e7ffc23 in kdemain () at /usr/lib/libkdeinit5_ksysguard.so
#29 0x00007fdf0e5ed223 in __libc_start_main () at /usr/lib/libc.so.6
#30 0x0000564a2e26905e in _start ()
[Inferior 1 (process 23739) detached]

Reported using DrKonqi
Comment 1 Christoph Feck 2019-02-08 16:10:18 UTC

*** This bug has been marked as a duplicate of bug 350140 ***