Bug 402642 - ATTENTION!
Summary: ATTENTION!
Status: RESOLVED DUPLICATE of bug 399864
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.12.6
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-12-28 11:42 UTC by Vlad
Modified: 2020-01-23 18:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vlad 2018-12-28 11:42:13 UTC
Application: plasmashell (5.12.6)

Qt Version: 5.9.5
Frameworks Version: 5.44.0
Operating System: Linux 4.15.0-29-generic x86_64
Distribution: Ubuntu 18.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
When you transfer a file from the training preview folder on the desktop to the root folder, the plasma does not occur! THIS IS REPEATED CONSTANTLY! TESTED ON MULTIPLE DIFFERENT COMPUTERS!

- Unusual behavior I noticed:
When you transfer a file from the training preview folder on the desktop to the root folder, the plasma does not occur! THIS IS REPEATED CONSTANTLY! TESTED ON MULTIPLE DIFFERENT COMPUTERS!

- Custom settings of the application:
Default

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2355756800 (LWP 3768))]

Thread 7 (Thread 0x7f2287f54700 (LWP 3923)):
#0  0x00007f234ed15bf9 in __GI___poll (fds=0x7f2280006070, nfds=1, timeout=3099421) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f234987f439 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f234987f54c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f234f66390b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f234f6089ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f234f42722a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f228a8b0747 in KCupsConnection::run() () from /usr/lib/x86_64-linux-gnu/libkcupslib.so
#7  0x00007f234f42c16d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f234e5a86db in start_thread (arg=0x7f2287f54700) at pthread_create.c:463
#9  0x00007f234ed2288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f231bdb9700 (LWP 3911)):
#0  0x00007f234e5ae9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x7f2355109fb8) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x7f2355109f68, cond=0x7f2355109f90) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x7f2355109f90, mutex=0x7f2355109f68) at pthread_cond_wait.c:655
#3  0x00007f2354e135f4 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#4  0x00007f2354e13639 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#5  0x00007f234e5a86db in start_thread (arg=0x7f231bdb9700) at pthread_create.c:463
#6  0x00007f234ed2288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f231c5ba700 (LWP 3910)):
#0  0x00007f23498c4cf4 in g_mutex_unlock () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f234987e988 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f234987f36b in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f234987f54c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f234f66390b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f234f6089ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f234f42722a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f23531332a6 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f234f42c16d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f234e5a86db in start_thread (arg=0x7f231c5ba700) at pthread_create.c:463
#10 0x00007f234ed2288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f232ac40700 (LWP 3837)):
#0  __GI___clock_gettime (clock_id=1, tp=0x7f232ac3faf0) at ../sysdeps/unix/clock_gettime.c:115
#1  0x00007f234f663221 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f234f661a59 in QTimerInfoList::updateCurrentTime() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f234f662035 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f234f66367e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f234987e998 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f234987f36b in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f234987f54c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f234f66390b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f234f6089ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f234f42722a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f23525996f5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#12 0x00007f234f42c16d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f234e5a86db in start_thread (arg=0x7f232ac40700) at pthread_create.c:463
#14 0x00007f234ed2288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f23371e2700 (LWP 3825)):
#0  0x00007f234987e8d3 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f234987f36b in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f234987f54c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f234f66390b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f234f6089ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f234f42722a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f23525996f5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f234f42c16d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f234e5a86db in start_thread (arg=0x7f23371e2700) at pthread_create.c:463
#9  0x00007f234ed2288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f233cdea700 (LWP 3789)):
#0  0x00007f234ed15bf9 in __GI___poll (fds=0x7f2330004db0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f234987f439 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f234987f54c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f234f66390b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f234f6089ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f234f42722a in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f234fae0d45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f234f42c16d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f234e5a86db in start_thread (arg=0x7f233cdea700) at pthread_create.c:463
#9  0x00007f234ed2288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f2355756800 (LWP 3768)):
[KCrash Handler]
#6  0x00007f234fe65fb4 in QDrag::supportedActions() const () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#7  0x00007f2341d1f06b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#8  0x00007f234fe4950c in QBasicDrag::eventFilter(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#9  0x00007f234f60a53c in QCoreApplicationPrivate::sendThroughApplicationEventFilters(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f2350612868 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#11 0x00007f235061a0f4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#12 0x00007f234f60a9a8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f234fe56523 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#14 0x00007f234fe57ff5 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#15 0x00007f234fe2f2eb in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#16 0x00007f2341d731c0 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#17 0x00007f234987f287 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f234987f4c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f234987f54c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f234f6638ef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f234f6089ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f234fe4a2d5 in QBasicDrag::drag(QDrag*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#23 0x00007f234fe694f1 in QDragManager::drag(QDrag*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#24 0x00007f234fe65d67 in QDrag::exec(QFlags<Qt::DropAction>, Qt::DropAction) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#25 0x00007f231d913c2b in FolderModel::dragSelectedInternal(int, int) () from /usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/private/desktopcontainment/folder/libfolderplugin.so
#26 0x00007f231d93443e in ?? () from /usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/private/desktopcontainment/folder/libfolderplugin.so
#27 0x00007f234f63a122 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f235061282c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#29 0x00007f235061a0f4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#30 0x00007f234f60a9a8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007f234f60d11d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#32 0x00007f234f6642c3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#33 0x00007f234987f287 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f234987f4c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f234987f54c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f234f6638ef in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#37 0x00007f234f6089ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#38 0x00007f234f611a84 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#39 0x00005593e633ccfa in ?? ()
#40 0x00007f234ec22b97 in __libc_start_main (main=0x5593e633c320, argc=1, argv=0x7ffe78b50b08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe78b50af8) at ../csu/libc-start.c:310
#41 0x00005593e633d09a in _start ()

Possible duplicates by query: bug 400273, bug 393703.

Reported using DrKonqi
Comment 1 David Edmundson 2018-12-28 11:55:30 UTC
Please do not be overly dramatic on bug reports.

Also, what is "the training preview folder"

*** This bug has been marked as a duplicate of bug 400273 ***
Comment 2 Nate Graham 2020-01-23 18:16:35 UTC

*** This bug has been marked as a duplicate of bug 399864 ***