Bug 402495 - web site Link to source code is broken
Summary: web site Link to source code is broken
Status: RESOLVED FIXED
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL: https://www.kde.org/applications/deve...
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-23 12:27 UTC by Brian G.
Modified: 2018-12-23 20:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian G. 2018-12-23 12:27:09 UTC
SUMMARY
The link to source code on the kdiff3 development webpage is broken.

STEPS TO REPRODUCE
1. Go to: https://www.kde.org/applications/development/kdiff3/development
2. Note the link labeled "Browse KDiff3 source code on WebSVN" points to: http://websvn.kde.org/trunk/extragear/utils/kdiff3/
3. Attempt to go there (clicking the link or otherwise) reports a 404.

OBSERVED RESULT
reports a 404 error.

EXPECTED RESULT
a functional link to the source code on the page listed in step 1, where one could browse the current source code.

SOFTWARE/OS VERSIONS
likely not relevant, but I was using Google Chrome 70.0.3538.110 to browse the site on 2018-12-23.

ADDITIONAL INFORMATION
Manually browsing the svn repo pages reveals that http://websvn.kde.org/trunk/extragear/utils/ does not contain a subdirectory kdiff3.  Perhaps the code has moved elsewhere and the site needs the link updated?

I don't think http://kdiff3.sourceforge.net/ is the correct URL here since the last official release of kdiff3 there is 0.9.98 from 2014-07-04, and I've used newer versions than this on several systems.  For example, my currently installed version of kdiff3 reports 1.7.90 when executed with the --version argument.

Sorry if this isn't the correct bug tracker to report website issues, but I didn't see any specific links for reporting web site issues.
Comment 1 michael 2018-12-23 13:49:53 UTC
Reassigning to www.kde.org product.
Comment 2 Unknown 2018-12-23 20:56:42 UTC
SVN commit 1531308 by bcooksley:

Update repository location for KDiff3


 M  +1 -1      kdiff3.json  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1531308