Bug 402079 - Adjusting volume by scrolling on system tray icon with reverse scrolling enabled on touchpad is unnatural.
Summary: Adjusting volume by scrolling on system tray icon with reverse scrolling enab...
Status: RESOLVED DUPLICATE of bug 390777
Alias: None
Product: plasma-pa
Classification: Plasma
Component: applet (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR minor
Target Milestone: ---
Assignee: David Rosca
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-13 05:32 UTC by Tim Carr
Modified: 2018-12-27 04:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Carr 2018-12-13 05:32:35 UTC
SUMMARY


STEPS TO REPRODUCE
1. Enable reverse vertical or "natural" scrolling on a device with a touchpad.
2. Scroll over volume icon in the system tray

OBSERVED RESULT
Scrolling down results in the audio level increasing and scrolling up decreases the volume. 

EXPECTED RESULT
While this is arguably expected behavior from enabling "reverse scrolling" it doesn't really make sense in the context of the volume control. Either detecting when reverse scrolling is enabled or possibly an option to set how the scrolling effects the volume would make use of the volume control feel more natural when reverse scrolling is enabled.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Kernel 4.19.6
(available in About System)
KDE Plasma Version: 5.14.4
KDE Frameworks Version: 5.52.0
Qt Version: 5.11.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2018-12-27 04:51:08 UTC

*** This bug has been marked as a duplicate of bug 402578 ***
Comment 2 Nate Graham 2018-12-27 04:51:34 UTC

*** This bug has been marked as a duplicate of bug 390777 ***