Bug 401020 - Feature Request: Edit "metered" property of network connection
Summary: Feature Request: Edit "metered" property of network connection
Status: RESOLVED FIXED
Alias: None
Product: plasma-nm
Classification: Unclassified
Component: editor (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jan Grulich
URL:
Keywords:
: 403898 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-14 00:18 UTC by DH
Modified: 2019-02-03 18:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.15.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DH 2018-11-14 00:18:37 UTC
I searched the bug list as best I could, but did not see anything relating to this as of yet. 

As of my installed plasma-nm version, 4:5.14.3-0ubuntu1~ubuntu18.10~ppa1, I do not see a GUI way to set the "metered" property of a NM managed connection in the "Connections" dialog. I would like to see a dropbox or toggle to set a specific connection's metered property to true / manually set. Of course, I can dig up how to do this on command line periodically, but that means more searching and using bandwidth on very expensive / tight connections to remember how first. 

Thanks.
Comment 1 Jan Grulich 2018-11-14 13:45:14 UTC
Git commit 4b549b2d37d8f942b6f821077b87baede447f791 by Jan Grulich.
Committed on 14/11/2018 at 13:43.
Pushed by grulich into branch 'master'.

Add metered property to general configuration
FIXED-IN: 5.15.0

M  +5    -12   libs/editor/settings/connectionwidget.cpp
M  +156  -162  libs/editor/settings/ui/connectionwidget.ui

https://commits.kde.org/plasma-nm/4b549b2d37d8f942b6f821077b87baede447f791
Comment 2 Jan Grulich 2019-02-03 18:30:36 UTC
*** Bug 403898 has been marked as a duplicate of this bug. ***