Bug 400947 - External references in HTML emails are not printed
Summary: External references in HTML emails are not printed
Status: RESOLVED DUPLICATE of bug 391030
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: Git (master)
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-11 21:20 UTC by Jonathan Marten
Modified: 2020-09-26 08:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test message (2.34 KB, application/mbox)
2018-11-11 21:20 UTC, Jonathan Marten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Marten 2018-11-11 21:20:44 UTC
Created attachment 116250 [details]
Test message

SUMMARY

Even if a HTML mail is displayed with external references (images) manually requested, the images are not printed or previewed.

STEPS TO REPRODUCE
1. Load the attached sample message into KMail.  It is has only one external reference and is safe to open, and contains no personal information.
2. Activate HTML message display with "by clicking here" at the end of the "Note: This is a HTML mesasage..." header.
3. Load external references with "by clicking here" at the end of the "Note: This HTML message..." header.
4. Observe that the white logo is shown in the blue box at the top.
5. Select File - Print Preview. In the preview observe that the logo is replaced by a "broken image" graphic.
6. Close the preview and select "Print..." to an printer or to a PDF file. Observe that the same "broken image" is printed.

OBSERVED RESULT

"Broken image" graphic when printing

EXPECTED RESULT

External referenced image shown when printing, as on the screen.

SOFTWARE/OS VERSIONS
Windows: 
MacOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.14.80
KDE Frameworks Version: 5.52.0
Qt Version: 5.11.2

ADDITIONAL INFORMATION

KMail configuration options:
Misc - Printing - Print background colour and images is set to ON.
Security - Reading - Prefer HTML to plain text is set to OFF.
Security - Reading - Allow messages to load external references is set to OFF.

Bug 391030 may be the same, but that does not make it clear whether HTML and/or external references are allowed or requested.
Comment 1 Saeid Akbari 2019-08-28 21:21:32 UTC
Same here. Still exists on KMail 19.04.3 with KDE Frameworks 5.60

There's also the poor quality printing issue present. Bug 378843.
Comment 2 Jonathan Marten 2020-09-26 08:41:15 UTC

*** This bug has been marked as a duplicate of bug 391030 ***