Bug 400849 - cannot open "CDDB information.txt" files from audio CDs: error "The file or folder /information/CDDB information.txt does not exist"
Summary: cannot open "CDDB information.txt" files from audio CDs: error "The file or f...
Status: RESOLVED FIXED
Alias: None
Product: AudioCD-KIO
Classification: Frameworks and Libraries
Component: General (show other bugs)
Version: 18.08.3
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-08 16:26 UTC by Patrick Silva
Modified: 2019-03-16 17:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (330.90 KB, image/png)
2018-11-08 16:26 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-11-08 16:26:33 UTC
Created attachment 116183 [details]
screenshot

SUMMARY
Dolphin shows the error message "The file or folder /information/CDDB information.txt does not exist" when I try to open "CDDB information.txt" files from audio CDs.

STEPS TO REPRODUCE
1. insert an audio cd and open dolphin
2. click "Audio CD" under "Removable devices"
3. open "Information" folder, try to open some TXT file listed

OBSERVED RESULT
Dolphin shows the error message "The file or folder /information/CDDB information.txt does not exist". Plasma shows a notification "Examining: failed". See my screenshot please.

EXPECTED RESULT
TXT files should be open without error messages.

SOFTWARE VERSIONS
Arch Linux
KDE Plasma Version: 5.14.3
KDE Frameworks Version: 5.51
Qt Version: 5.12 beta4
Comment 1 Patrick Silva 2019-02-14 17:06:29 UTC
Bug persists.

Operating System: Arch Linux 
KDE Plasma Version: 5.15.0
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.1
Comment 2 Yuri Chornoivan 2019-02-14 17:17:56 UTC
Actually, it looks like the problem with KIO transparency. If you copy the file somewhere it just can be opened fine. I've tried to figure out what it is but failed.

I would be obliged for the hints on how to make audiocd:/information as transparent for Kate as ftp:/.
Comment 3 Albert Astals Cid 2019-03-16 17:49:45 UTC
Git commit b49238ba899300ebf54a437dc9de9a04b88cecbd by Albert Astals Cid.
Committed on 16/03/2019 at 17:49.
Pushed by aacid into branch 'Applications/19.04'.

Fix stat to actually recognize the info dir exists

Summary: BUGS: 400849

Test Plan: Works for me

Reviewers: yurchor

Reviewed By: yurchor

Subscribers: #kde_applications, yurchor

Differential Revision: https://phabricator.kde.org/D19086

M  +47   -4    audiocd.cpp

https://commits.kde.org/audiocd-kio/b49238ba899300ebf54a437dc9de9a04b88cecbd