Bug 400846 - Outbox can't edit a saved item
Summary: Outbox can't edit a saved item
Status: RESOLVED DUPLICATE of bug 389944
Alias: None
Product: kmymoney
Classification: Unclassified
Component: onlinebanking (show other bugs)
Version: 5.0.2
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-08 12:41 UTC by Fabiano Caruana
Modified: 2019-09-21 12:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.7


Attachments
Button "Edit" is not active (101.34 KB, image/png)
2018-11-08 12:41 UTC, Fabiano Caruana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabiano Caruana 2018-11-08 12:41:02 UTC
Created attachment 116181 [details]
Button "Edit" is not active

SUMMARY
Outbox can't edit a saved item

STEPS TO REPRODUCE
1. Edit a new item and save 
2. After saving I can't never edit
3. Also an old item for copy is not possible 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE VERSIONS
5.0.2
KDE Plasma Version: 5.14.2
KDE Frameworks Version: 5.51.0
Qt Version: 5.11.2

ADDITIONAL INFORMATION
Comment 1 Fabiano Caruana 2018-12-04 14:25:32 UTC
Forget this Bug.
I never have interest on an answer

Thats Bugzilla :-(

Bye
Comment 2 Jack 2018-12-04 18:33:10 UTC
I'll be glad to close this as NOT A BUG, unless someone can confirm it really is a bug.  I don't use this feature, so can't test myself.
Comment 3 Stefan Vater 2018-12-05 08:42:53 UTC
Formerly, you could select an item and "edit" it. However, editing in my case mostly ment to copy it for a new credit transfer, which was quite handy in my opinion. Right now, the "edit" button is always disabled in my case, even if I set up a credit transfer to send it later.

It would be nice to have at least a copy button and a measure to see more details of old credit transfers. Right now, I can only see the account, action and recipient. Also investigating the amount and the reason for payment ("Verwendungszweck") would be very handy.
Comment 4 Thomas Baumgart 2018-12-05 09:40:14 UTC
I can confirm all that has been said and reported.
Comment 5 Fabiano Caruana 2019-05-24 14:57:58 UTC
I am currently working in the test area with OpenSuse LEAP 15.1
It is updated to KMyMOney version 5.0.4.
Unfortunately, nothing has changed with regard to the topic "Outbox" in version 5.0.4.
There is a possibility to deactivate the button "Outbox", because it does not work correctly anyway.
Unfortunately, a process once saved can not be re-edited (for example, in the event of a wrong entry).
The copy of a transaction is unfortunately not possible, then only the data of the transfer to adapt, not possible.
Currently I log in to my bank separately to do overweights, it is easier than always to delete and re-edit.
This has worked until version 5.0.1, not since 5.0.2.
Confirmed non-function already since 05 December 2018 in Bugzilla.
If this function really should not be possible, please disable it completely.
Thank you.
Comment 6 Fabiano Caruana 2019-07-09 12:03:45 UTC
I have seen that in version 5.0.4 the function "Outbox" can be activated / deactivated in the settings under Modules.
It is a pity that this does not work anymore, but I have to live with it.
I have deactivated it in my installation.

greetings
Udo
Comment 7 Thomas Baumgart 2019-09-21 12:59:02 UTC

*** This bug has been marked as a duplicate of bug 389944 ***