Bug 400795 - Support Flatpak application extensions
Summary: Support Flatpak application extensions
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: Flatpak Backend (show other bugs)
Version: 5.13.5
Platform: Debian testing Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-07 11:03 UTC by Mikaela Suomalainen
Modified: 2018-11-08 15:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.15.0


Attachments
Screenshot showing gnome-software and plasma-discover on HexChat details, where the plugins are visible (179.29 KB, image/png)
2018-11-07 11:03 UTC, Mikaela Suomalainen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikaela Suomalainen 2018-11-07 11:03:54 UTC
Created attachment 116148 [details]
Screenshot showing gnome-software and plasma-discover on HexChat details, where the plugins are visible

SUMMARY

Searching for a flatpak that uses extensions, for example HexChat, the extensions aren't shown, they have to be installed either from terminal or gnome-software.

STEPS TO REPRODUCE
1. Search for HexChat (and compare also to "flatpak search hexchat").
2. Open HexChat details in Discover as they aren't shown in search.
3. There are no extensions mentioned.

OBSERVED RESULT

No extensions are shown in Discover, while they are listed by "flatpak search" and GNOME-software.

EXPECTED RESULT

I would expect to see the extensions in search or preferably in HexChat details as GNOME-software does.

SOFTWARE VERSIONS
(available in About System)
KDE Plasma Version: 5.13.5
KDE Frameworks Version: 5.49.0
Qt Version: 5.11.2

ADDITIONAL INFORMATION

I think https://github.com/flatpak/flatpak/wiki/Extensions is the flatpak documentation on extensions, but it seems to be intended towards flatpak packagers. The attachement is a screenshot showing gnome-software and plasma-discover on the same page (assuming they are the same page).

Lisäosat = plugins/extensions, asennettu = installed
Comment 1 Aleix Pol 2018-11-08 15:37:49 UTC
Git commit 5673ade2c9e0895150c23f7cf4e984b95da87c94 by Aleix Pol.
Committed on 08/11/2018 at 15:35.
Pushed by apol into branch 'master'.

flatpak: allow listing extensions

M  +9    -2    libdiscover/backends/FlatpakBackend/FlatpakBackend.cpp
M  +2    -0    libdiscover/backends/FlatpakBackend/FlatpakBackend.h
M  +20   -6    libdiscover/backends/FlatpakBackend/FlatpakResource.cpp
M  +2    -0    libdiscover/backends/FlatpakBackend/FlatpakResource.h

https://commits.kde.org/discover/5673ade2c9e0895150c23f7cf4e984b95da87c94