Bug 400720 - Impossible to dismiss the app dashboard clicking on the empty area below search results
Summary: Impossible to dismiss the app dashboard clicking on the empty area below sear...
Status: RESOLVED FIXED
Alias: None
Product: kdeplasma-addons
Classification: Plasma
Component: Application Dashboard (show other bugs)
Version: 5.14.2
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords: junior-jobs, usability
Depends on:
Blocks:
 
Reported: 2018-11-05 22:48 UTC by Patrick Silva
Modified: 2018-11-24 05:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.12.8


Attachments
screenshot (2.15 MB, image/png)
2018-11-05 22:48 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-11-05 22:48:50 UTC
Created attachment 116116 [details]
screenshot

SUMMARY
We can dismiss the app dashboard clicking on some empty area of it,
except when the empty area is below the search results.

STEPS TO REPRODUCE
1. open the app dashboard and type some random letters
2. click on the empty area below search field
3. 

OBSERVED RESULT
nothing, app dashboard remains open

EXPECTED RESULT
app dashboard should be closed

SOFTWARE VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.14.2
Qt Version: 5.12.0 beta3
KDE Frameworks Version: 5.51.0

ADDITIONAL INFORMATION
My screenshot shows the empty area where
click is not enough to close the app dashboard.
Comment 1 Nate Graham 2018-11-05 22:53:00 UTC
Looks like the results view should allow click-through, or else dismiss the whole thing when an empty area is clicked on.
Comment 2 Eike Hein 2018-11-19 07:03:24 UTC
The problem is actually in ItemMultiGridView, and also affects the "All Applications" page (inbetween categories).
Comment 3 Eike Hein 2018-11-21 13:32:58 UTC
Git commit e12e3cad1d7ee8c2f95cecd5939a648b508a408e by Eike Hein.
Committed on 21/11/2018 at 13:32.
Pushed by hein into branch 'Plasma/5.12'.

Fix dismissing the Dashboard by clicking inbetween multi-grid categories.

Summary:
Or on category headers.

Reviewers: #plasma

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D17005

M  +1    -1    applets/kicker/package/contents/ui/DashboardRepresentation.qml
M  +9    -0    applets/kicker/package/contents/ui/ItemMultiGridView.qml

https://commits.kde.org/plasma-desktop/e12e3cad1d7ee8c2f95cecd5939a648b508a408e