Bug 400671 - Text and checkboxes out of position in standalone Mouse KCM when system language is pt-br
Summary: Text and checkboxes out of position in standalone Mouse KCM when system langu...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords: usability
: 400673 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-04 17:00 UTC by Patrick Silva
Modified: 2018-11-20 18:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (99.42 KB, image/png)
2018-11-04 17:00 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-11-04 17:00:23 UTC
Created attachment 116085 [details]
screenshot

STEPS TO REPRODUCE
1. search for "mouse" kcm in the apps launcher or krunner (alt+f2) and open it
2. 
3. 

OBSERVED RESULT
text and checkboxes out of the position, see the screenshot please.

EXPECTED RESULT
texts and checkboxes are positioned correctly

SOFTWARE VERSIONS
KDE neon Developer Edition
KDE Plasma: 5.14.80
VQt: 5.11.2
KDE Frameworks: 5.52.0


ADDITIONAL INFORMATION
mouse KCM looks correct in system settings.
Comment 1 Patrick Silva 2018-11-04 17:06:24 UTC
I forgot to say that the bug occurs when system language is pt-br.
No problem when system language is english.
Comment 2 Nate Graham 2018-11-05 17:23:44 UTC
I can actually get this to happen in English the first time I open System Settings on a fresh install of Plasma 5.14.2. If I resize the window to be really wide and then make it smaller again, the layout problem disappears. I believe this is the fault of Kirigami's FormLayout trying to be too smart about adjusting its layout to fit the available space.
Comment 3 Nate Graham 2018-11-05 19:32:09 UTC
*** Bug 400673 has been marked as a duplicate of this bug. ***
Comment 4 Marco Martin 2018-11-20 18:44:14 UTC
Git commit fa7a469416ee3ccc172d2d0029bc551b948abda0 by Marco Martin.
Committed on 20/11/2018 at 18:43.
Pushed by mart into branch 'master'.

ensure all items are laid out

work around a  GridLayout quirk which doesn't lay out items with null
size hints
causing things to be laid out incorrectly in some cases

M  +7    -3    src/controls/FormLayout.qml

https://commits.kde.org/kirigami/fa7a469416ee3ccc172d2d0029bc551b948abda0