Bug 400518 - Can't send click events to the non-focused page (but can send other kinds of events)
Summary: Can't send click events to the non-focused page (but can send other kinds of ...
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Applications
Component: discover (show other bugs)
Version: 5.14.2
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-31 16:19 UTC by Patrick Silva
Modified: 2018-11-14 14:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.53


Attachments
demonstration (2.37 MB, video/webm)
2018-11-05 13:05 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-10-31 16:19:59 UTC
STEPS TO REPRODUCE
1. open discover
2. click some app in "featured" page to open its description (notice greyed out "featured" in the header bar)
3. click some "install/remove" button under "Featured" column

OBSERVED RESULT
the app is not installed/removed. The button only is highlighted and "Featured" in the header bar is no longer greyed out.

EXPECTED RESULT
discover installs/removes the app

SOFTWARE VERSIONS
Arch Linux
KDE Plasma Version: 5.14.2 
KDE Frameworks Version: 5.51
Qt Version: 5.12 beta3
Comment 1 Nate Graham 2018-11-03 04:25:48 UTC
[Discover must be in widescreen view to trigger this bug]

I see the problem here: the first time you click on the install button it doesn't actually get clicked; the click gets eaten to return focus to the list view. Once it's focused, then clicking on the button works as expected and the app is installed.

Aleix, is this a Kirigami issue, or something in Discover?
Comment 2 Aleix Pol 2018-11-05 12:00:37 UTC
I cannot reproduce, can you maybe provide a video showing it?
Also can you test if it also happens if you set Flatpak or Snap as the default backend?
Comment 3 Patrick Silva 2018-11-05 13:05:07 UTC
Created attachment 116103 [details]
demonstration
Comment 4 Aleix Pol 2018-11-05 16:43:05 UTC
This is some behavior enforced from Kirigami.
Comment 5 Marco Martin 2018-11-14 10:14:37 UTC
Git commit 8eaf0319651a30369bfee87b75042d75aaf7486c by Marco Martin.
Committed on 14/11/2018 at 10:13.
Pushed by mart into branch 'master'.

change index on pressed, not on clicked

click events aren't eated anymore

M  +2    -1    src/controls/PageRow.qml

https://commits.kde.org/kirigami/8eaf0319651a30369bfee87b75042d75aaf7486c