Bug 400517 - Replace hamburger menus on Settings page with pushbuttons
Summary: Replace hamburger menus on Settings page with pushbuttons
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: 5.14.2
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2018-10-31 16:04 UTC by Patrick Silva
Modified: 2018-11-06 20:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.15.0


Attachments
screenshot (125.59 KB, image/png)
2018-10-31 16:04 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-10-31 16:04:00 UTC
Created attachment 116005 [details]
screenshot

STEPS TO REPRODUCE
1. open discover
2. click "settings" in the side bar, click hamburger button related to flatpak backend and set it as default
3. click hambuger button related to your distro repos

OBSERVED RESULT
An entry in hamburger menu looks empty/cut off. See the screenshot please.


SOFTWARE VERSIONS
Arch Linux
KDE Plasma Version: 5.14.2
KDE Frameworks Version: 5.51
Qt Version: 5.12 beta3
Comment 1 Nate Graham 2018-11-01 19:10:21 UTC
The menu is just too tall, which is a bug in Kirigami or the QQC2 style (not sure which one).

However, a menu with just one item is silly. Aleix, can we remove these hamburger menus and just add their items to the applicable header as buttons? We already do this for the PackageKit configuration button; might as well do it for everything IMHO since now we have silly one-item menus. I think that would be more user-friendly and nicer-looking.
Comment 2 Aleix Pol 2018-11-05 14:02:18 UTC
This fixes the actual issue.
We can drop the hamburger, I'm not a big fan of the buttons there, tested it in the past and it looked odd, but maybe it's the way to go.

This patch fixes the issue Patrick is complaining about: https://phabricator.kde.org/D16685
Comment 3 Nate Graham 2018-11-05 14:17:41 UTC
We already have a button on the header row though: it's just an unlabeled button that opens a single-item menu. :) Last time I tried replacing this with buttons for the individual menu items, I thought it looked pretty good, but then again I am a notorious button-lover.

I'll give that patch a whirl, regardless.
Comment 4 Aleix Pol 2018-11-05 15:32:51 UTC
Git commit 8fa114df0ad1d53362c13e9446b43143a6dd450b by Aleix Pol.
Committed on 05/11/2018 at 15:30.
Pushed by apol into branch 'master'.

Fix issue where there's only one element on the menu

Summary:
This (random) height shows an odd padding on the menu when there's just the one
element.

Test Plan: I don't get it anymore on Discover

Reviewers: #frameworks, mart, ngraham

Reviewed By: mart, ngraham

Subscribers: ngraham, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D16685

M  +0    -1    org.kde.desktop/Menu.qml

https://commits.kde.org/qqc2-desktop-style/8fa114df0ad1d53362c13e9446b43143a6dd450b
Comment 5 Aleix Pol 2018-11-06 16:48:47 UTC
Git commit 68c9d420321f96b3c4d9d64d1276ef3ffb2933db by Aleix Pol.
Committed on 06/11/2018 at 16:48.
Pushed by apol into branch 'master'.

Remove hamburger menu

M  +14   -24   discover/qml/SourcesPage.qml

https://commits.kde.org/discover/68c9d420321f96b3c4d9d64d1276ef3ffb2933db