Bug 400515 - Crash when closing KSysGuard normally
Summary: Crash when closing KSysGuard normally
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.14.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-10-31 14:30 UTC by darrikmarion
Modified: 2018-11-09 12:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description darrikmarion 2018-10-31 14:30:20 UTC
Application: ksysguard (5.14.2)

Qt Version: 5.11.1
Frameworks Version: 5.51.0
Operating System: Linux 4.19.0-041900-generic x86_64
Distribution: Ubuntu 18.10

-- Information about the crash:
- What I was doing when the application crashed:
I was viewing typical metrics about my system, went to the titlebar and closed the program. I then got the crash handler telling me that it crashed. I opened it again and closed it the same way but nothing happened.

The crash does not seem to be reproducible.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f23ebbe1940 (LWP 8967))]

Thread 5 (Thread 0x7f23e0f76700 (LWP 8973)):
#0  0x00007f23f271d2eb in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55f264a69d68) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007f23f271d2eb in __pthread_cond_wait_common (abstime=0x0, mutex=0x55f264a69d18, cond=0x55f264a69d40) at pthread_cond_wait.c:502
#2  0x00007f23f271d2eb in __pthread_cond_wait (cond=0x55f264a69d40, mutex=0x55f264a69d18) at pthread_cond_wait.c:655
#3  0x00007f23e165b46b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f23e165b1d7 in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f23f2717164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#6  0x00007f23f8849def in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f23e3fff700 (LWP 8971)):
#0  0x00007f23f8838f64 in __GI___libc_read (fd=7, buf=0x7f23e3ffea10, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:26
#1  0x00007f23f1627180 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f23f15e191f in g_main_context_check () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f23f15e1df0 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f23f15e1f6c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f23f6f9e15b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f23f6f4b16b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f23f6d9a0b6 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f23f72f3545 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007f23f6da3c87 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f23f2717164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#11 0x00007f23f8849def in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f23e9757700 (LWP 8970)):
#0  0x00007f23f883d6d9 in __GI___poll (fds=0x7f23e9756b78, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f23f2b78917 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f23f2b7a53a in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f23eb28b159 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f23f6da3c87 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f23f2717164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#6  0x00007f23f8849def in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f23ebbdd700 (LWP 8969)):
#0  0x00007f23f271d2eb in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x7f23f6674130) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007f23f271d2eb in __pthread_cond_wait_common (abstime=0x0, mutex=0x55f264884580, cond=0x7f23f6674108) at pthread_cond_wait.c:502
#2  0x00007f23f271d2eb in __pthread_cond_wait (cond=0x7f23f6674108, mutex=0x55f264884580) at pthread_cond_wait.c:655
#3  0x00007f23f6c0e83c in std::condition_variable::wait(std::unique_lock<std::mutex>&) () at /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#4  0x00007f23f59b5847 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#5  0x00007f23f59b5989 in  () at /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5
#6  0x00007f23f6c1463f in  () at /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#7  0x00007f23f2717164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#8  0x00007f23f8849def in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f23ebbe1940 (LWP 8967)):
[KCrash Handler]
#6  0x00007f23f6e169a6 in operator==(QString const&, QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f23f7b63967 in QLabel::setText(QString const&) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007f23f898b454 in  () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#9  0x00007f23f85d9c39 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#10 0x00007f23f85e0fee in  () at /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#11 0x00007f23f6f75830 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f23f6edfd9a in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f23f6ee588d in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f23f6ee5cd0 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f23f6f756db in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f23f6f80f19 in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f23f6f81261 in QSocketNotifier::event(QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007f23f7a394a1 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007f23f7a40ae0 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007f23f6f4c499 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f23f6f9ed6a in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f23f15e1c3e in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f23f15e1ed8 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f23f15e1f6c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f23f6f9e143 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007f23eb31ce51 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#27 0x00007f23f6f4b16b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f23f6f532e2 in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f23f898d1ab in kdemain () at /usr/lib/x86_64-linux-gnu/libkdeinit5_ksysguard.so
#30 0x00007f23f875309b in __libc_start_main (main=0x55f263921050, argc=1, argv=0x7ffdb26822a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffdb2682298) at ../csu/libc-start.c:308
#31 0x000055f26392108a in _start ()
[Inferior 1 (process 8967) detached]

Reported using DrKonqi
Comment 1 Christoph Feck 2018-11-09 12:53:57 UTC

*** This bug has been marked as a duplicate of bug 350140 ***