Bug 400375 - ksysguard crash on exit
Summary: ksysguard crash on exit
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.14.2
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-10-27 18:53 UTC by petrk
Modified: 2018-10-28 04:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
my custom tab (4.04 KB, application/x-ksysguard)
2018-10-27 18:54 UTC, petrk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description petrk 2018-10-27 18:53:42 UTC
Application: ksysguard (5.14.2)

Qt Version: 5.11.2
Frameworks Version: 5.51.0
Operating System: Linux 4.18.16-zen1-1-zen x86_64
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
I was looking at my custon tab, then decided to close ksysguard.

- Custom settings of the application:

custom tab with sensors

-- Backtrace:
Application: Monitor systemowy (ksysguard), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f64e01e3000 (LWP 18854))]

Thread 5 (Thread 0x7f64d508f700 (LWP 19332)):
#0  0x00007f64e6f6bafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f64d56a41ac in  () at /usr/lib/dri/i965_dri.so
#2  0x00007f64d56a3ee8 in  () at /usr/lib/dri/i965_dri.so
#3  0x00007f64e6f65a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f64ed1b1b23 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f64dc907700 (LWP 19203)):
#0  0x00007f64ed1a6c21 in poll () at /usr/lib/libc.so.6
#1  0x00007f64e66e5ee0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f64e66e5fce in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f64eb946fe4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f64eb8f28cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f64eb73beb9 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f64ebc33ba6 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007f64eb745f65 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f64e6f65a9d in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f64ed1b1b23 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f64ddf81700 (LWP 18971)):
#0  0x00007f64ed1a6c21 in poll () at /usr/lib/libc.so.6
#1  0x00007f64e73c4630 in  () at /usr/lib/libxcb.so.1
#2  0x00007f64e73c62db in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3  0x00007f64df855c5a in  () at /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f64eb745f65 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007f64e6f65a9d in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f64ed1b1b23 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f64e01dc700 (LWP 18962)):
#0  0x00007f64e6f6bafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f64eb5a8cd1 in __gthread_cond_wait (__mutex=<optimized out>, __cond=<optimized out>) at /build/gcc/src/gcc-build/x86_64-pc-linux-gnu/libstdc++-v3/include/x86_64-pc-linux-gnu/bits/gthr-default.h:864
#2  0x00007f64eb5a8cd1 in std::condition_variable::wait(std::unique_lock<std::mutex>&) (this=<optimized out>, __lock=...) at /build/gcc/src/gcc/libstdc++-v3/src/c++11/condition_variable.cc:53
#3  0x00007f64ea3e1f14 in  () at /usr/lib/libQt5WebKit.so.5
#4  0x00007f64ea3e2039 in  () at /usr/lib/libQt5WebKit.so.5
#5  0x00007f64eb5af063 in std::execute_native_thread_routine(void*) (__p=0x55c92051ad80) at /build/gcc/src/gcc/libstdc++-v3/src/c++11/thread.cc:80
#6  0x00007f64e6f65a9d in start_thread () at /usr/lib/libpthread.so.0
#7  0x00007f64ed1b1b23 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f64e01e3000 (LWP 18854)):
[KCrash Handler]
#6  0x00007f64ec4c784c in  () at /usr/lib/libQt5Widgets.so.5
#7  0x00007f64ec4c839c in QLabel::setText(QString const&) () at /usr/lib/libQt5Widgets.so.5
#8  0x00007f64ed2eae15 in  () at /usr/lib/libkdeinit5_ksysguard.so
#9  0x00007f64ecf5c5b9 in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/libksgrd.so.7
#10 0x00007f64ecf63cd0 in  () at /usr/lib/libksgrd.so.7
#11 0x00007f64eb91dbd0 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#12 0x00007f64eb8862eb in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () at /usr/lib/libQt5Core.so.5
#13 0x00007f64eb88bf44 in  () at /usr/lib/libQt5Core.so.5
#14 0x00007f64eb88c3a0 in  () at /usr/lib/libQt5Core.so.5
#15 0x00007f64eb91da7c in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#16 0x00007f64eb9296ba in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () at /usr/lib/libQt5Core.so.5
#17 0x00007f64eb929a12 in QSocketNotifier::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#18 0x00007f64ec397e14 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#19 0x00007f64ec39f6e1 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#20 0x00007f64eb8f3c39 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#21 0x00007f64eb947c2b in  () at /usr/lib/libQt5Core.so.5
#22 0x00007f64e66e43cf in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#23 0x00007f64e66e5f89 in  () at /usr/lib/libglib-2.0.so.0
#24 0x00007f64e66e5fce in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#25 0x00007f64eb946fc9 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#26 0x00007f64df8ebe12 in  () at /usr/lib/libQt5XcbQpa.so.5
#27 0x00007f64eb8f28cc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#28 0x00007f64eb8fabc6 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#29 0x00007f64ed2ecc23 in kdemain () at /usr/lib/libkdeinit5_ksysguard.so
#30 0x00007f64ed0da223 in __libc_start_main () at /usr/lib/libc.so.6
#31 0x000055c91ff5605e in _start ()
[Inferior 1 (process 18854) detached]

Reported using DrKonqi
Comment 1 petrk 2018-10-27 18:54:41 UTC
Created attachment 115923 [details]
my custom tab
Comment 2 Christoph Feck 2018-10-28 04:06:46 UTC

*** This bug has been marked as a duplicate of bug 350140 ***