Bug 400279 - vex amd64->IR: unhandled instruction bytes: 0xF 0xC7 0xF0 0xBA 0x1 0x0 0x0 0x0 0x89 0x3
Summary: vex amd64->IR: unhandled instruction bytes: 0xF 0xC7 0xF0 0xBA 0x1 0x0 0x0 0x...
Status: RESOLVED DUPLICATE of bug 353370
Alias: None
Product: valgrind
Classification: Developer tools
Component: general (show other bugs)
Version: 3.14 SVN
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-25 08:26 UTC by Sebastian Groth
Modified: 2018-10-25 17:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Groth 2018-10-25 08:26:34 UTC
vex amd64->IR: unhandled instruction bytes: 0xF 0xC7 0xF0 0xBA 0x1 0x0 0x0 0x0 0x89 0x3
vex amd64->IR:   REX=0 REX.W=0 REX.R=0 REX.X=0 REX.B=0
vex amd64->IR:   VEX=0 VEX.L=0 VEX.nVVVV=0x0 ESC=0F
vex amd64->IR:   PFX.66=0 PFX.F2=0 PFX.F3=0
==4764== valgrind: Unrecognised instruction at address 0xbc09743.
==4764==    at 0xBC09743: QRandomGenerator::SystemGenerator::generate(unsigned int*, unsigned int*) (in /usr/lib64/libQt5Core.so.5.11.1)

QtCore has been build with: x86_64-pc-linux-gnu-g++ -march=skylake -O2 (gcc version: Gentoo 7.3.0-r3 p1.4)
Comment 1 Mark Wielaard 2018-10-25 17:34:33 UTC
(In reply to Sebastian Groth from comment #0)
> vex amd64->IR: unhandled instruction bytes: 0xF 0xC7 0xF0 0xBA 0x1 0x0 0x0
> 0x0 0x89 0x3
> vex amd64->IR:   REX=0 REX.W=0 REX.R=0 REX.X=0 REX.B=0
> vex amd64->IR:   VEX=0 VEX.L=0 VEX.nVVVV=0x0 ESC=0F
> vex amd64->IR:   PFX.66=0 PFX.F2=0 PFX.F3=0
> ==4764== valgrind: Unrecognised instruction at address 0xbc09743.
> ==4764==    at 0xBC09743:
> QRandomGenerator::SystemGenerator::generate(unsigned int*, unsigned int*)
> (in /usr/lib64/libQt5Core.so.5.11.1)

That is the RDRAND instruction.

> QtCore has been build with: x86_64-pc-linux-gnu-g++ -march=skylake -O2

Don't use -march=skylake, the program needs to check whether or not the processor (that valgrind emulates) support rdrand (valgrind doesn't).

*** This bug has been marked as a duplicate of bug 353370 ***