Bug 399647 - PackageKit sources show up as "undefined"
Summary: PackageKit sources show up as "undefined"
Alias: None
Product: Discover
Classification: Applications
Component: discover (show other bugs)
Version: 5.14.0
Platform: Neon Linux
: NOR major
Target Milestone: ---
Assignee: Aleix Pol
: 399759 (view as bug list)
Depends on:
Reported: 2018-10-11 08:59 UTC by Ivan
Modified: 2018-11-11 10:36 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:

Screenshot (48.83 KB, image/png)
2018-10-11 08:59 UTC, Ivan

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan 2018-10-11 08:59:16 UTC
Created attachment 115556 [details]

After installing version 5.14.0 it is no longer possible to use the "settings" section with satisfaction

1. Open Discover
2. Go to "Settings"

Every line of the grid shows "undefined"

Possibility to configure repositories

(available in About System)
KDE Plasma Version: 5.14.0
KDE Frameworks Version: 5.50.0
Qt Version: 5.11.1

Linux distribution: KDE Neon based on Ubuntu Bionic
Comment 1 Nicola Zanardi 2018-10-11 11:19:20 UTC
Tried to reproduce the issue on a fresh neon unstable VM, and it seems to work properly for me.

KDE Plasma Version: 5.14.80
KDE Frameworks Version: 5.51.0
Qt Version: 5.11.1
Comment 2 Aleix Pol 2018-10-11 15:05:22 UTC
Please make sure your system is up to date.
Comment 3 Ivan 2018-10-12 08:35:13 UTC
On my PC I have a fresh neon based on bionic. I constantly updated the system until, after the 5.14.0 plasma update, Discover presented this problem.

"sudo apt-get update" output is fine without any warning or error.

In this old changelog:
in Discover sections, it said:

"Don't show "undefined" on the settings page if there's no extra info."

I don't know exactly what "extra info" means, but it describes my problem
Comment 4 Nate Graham 2018-10-12 19:30:57 UTC
Updating doesn't help; I experience this on git master too.
Comment 5 Nate Graham 2018-10-13 19:48:49 UTC
*** Bug 399759 has been marked as a duplicate of this bug. ***
Comment 6 Aleix Pol 2018-10-16 00:14:50 UTC
I've really tried hard to reproduce this and have been unable to in any helpful way. I found a neon iso that does but then compiling myself didn't make a different. I'm afraid we're hitting some kind of Qt problem.

Would any of you be able to run this discover with this patch and tell me what's the output you get?

diff --git a/libdiscover/resources/SourcesModel.cpp b/libdiscover/resources/SourcesModel.cpp
index 4c5ddd2c..b9047b7c 100644
--- a/libdiscover/resources/SourcesModel.cpp
+++ b/libdiscover/resources/SourcesModel.cpp
@@ -74,6 +74,7 @@ const QAbstractItemModel * SourcesModel::modelAt(const QModelIndex& index) const
 QVariant SourcesModel::data(const QModelIndex& index, int role) const
     if (!index.isValid()) return {};
+    qDebug() << "data" << index << role;
     switch (role) {
         case SourceNameRole:
             return modelAt(index)->property(DisplayName);
Comment 7 Robert Griffiths 2018-10-16 09:13:43 UTC
It works after this mornings update:

discover/bionic,now 2.1.2-8 amd64 [installed]
discover-data/bionic,bionic,now 2.2013.01.11 all [installed,automatic]
libdiscover2/bionic,now 2.1.2-8 amd64 [installed,automatic]
plasma-discover/bionic,now 5.14.0+p18.04+git20181016.0050-0 amd64 [installed,automatic]
plasma-discover-common/bionic,bionic,bionic,now 5.14.0+p18.04+git20181016.0050-0 all [installed,automatic]
plasma-discover-flatpak-backend/bionic,now 5.14.0+p18.04+git20181016.0050-0 amd64 [installed,automatic]
plasma-discover-private/bionic,now 5.14.0+p18.04+git20181016.0050-0 amd64 [installed,automatic]
plasma-discover-snap-backend/bionic,now 5.14.0+p18.04+git20181016.0050-0 amd64 [installed,automatic]
plasma-discover-updater/bionic,now 5.14.0+p18.04+git20181016.0050-0 amd64 [installed,automatic]
Comment 8 Robert Griffiths 2018-10-16 09:14:47 UTC
It works after this mornings updates...... on Neon Dev Stable 18.04
Comment 9 johansenmeister 2018-10-17 14:49:08 UTC
Problem persists on KDE Neon 18.04 User Edition
Comment 10 Ivan 2018-10-18 12:52:33 UTC
Today I received the plasma update (5.14.1) and the problem has disappeared, so I think we can consider the bug fixed.
Comment 11 Nate Graham 2018-10-18 13:06:39 UTC
Gone for me too. Closing, phew.
Comment 12 Bhushan Shah 2018-10-24 12:01:13 UTC
I can reliably reproduce this on phone
Comment 13 Aleix Pol 2018-10-24 13:04:04 UTC
With the device just flashed, I don't get the issue.
Comment 14 Aleix Pol 2018-10-29 13:26:56 UTC
Please investigate, I'm pretty sure it's working on Plasma Mobile too.
Comment 15 Dimitris Kardarakos 2018-11-11 10:36:55 UTC
Maybe totally irrelevant, but FWIW after installing package fwupd in plasma mobile rootfs pm-rootfs-20181110-183644.tar.gz I don't face the issue anymore.