Bug 399570 - Akregator crashes after clicking on link in an open tab
Summary: Akregator crashes after clicking on link in an open tab
Status: CONFIRMED
Alias: None
Product: akregator
Classification: Applications
Component: internal browser (show other bugs)
Version: 5.8.3
Platform: Fedora RPMs Linux
: NOR normal with 70 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 404765 404815 407688 408811 409572 412771 415945 419130 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-09 17:14 UTC by talha.khan1
Modified: 2022-03-27 13:08 UTC (History)
18 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (31.02 KB, text/plain)
2019-08-19 23:58 UTC, Pierre Maraval
Details
Backtrace generated by the KCrash handler after the segfault (47.36 KB, text/plain)
2019-10-08 06:55 UTC, Jonáš Vidra
Details
New crash information added by DrKonqi (36.51 KB, text/plain)
2019-10-17 16:29 UTC, Szőts Ákos
Details
New crash information added by DrKonqi (39.63 KB, patch)
2020-06-17 16:26 UTC, John Scott
Details
New crash information added by DrKonqi (39.63 KB, patch)
2020-06-17 16:26 UTC, John Scott
Details
New crash information added by DrKonqi (47.51 KB, text/plain)
2020-10-30 18:08 UTC, Don Curtis
Details
Akregator back trace (3.63 KB, text/plain)
2022-03-27 13:08 UTC, Colin J Thomson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description talha.khan1 2018-10-09 17:14:29 UTC
SUMMARY

Clicking on a particular link in an open tab causes akregator to crash

STEPS TO REPRODUCE
1. Add linux.com RSS feeds to akregator
2. Open the link for the article "How Linux is changing the face of end-user computing" (link url is https://www.linux.com/news/how-linux-changing-face-end-user-computing) in a new tab in akregator
3. Click on the link to Forbes at the bottom ("Read more at Forbes") (URL is https://www.forbes.com/sites/forbestechcouncil/2018/10/09/how-linux-is-changing-the-face-of-end-user-computing/#406ddbd74f15)

OBSERVED RESULT

Akregator crashes and closes. Nothing is reported to abrt (Problem Reporting).

EXPECTED RESULT

Link opens in same tab

SOFTWARE VERSIONS
(available in About System)
KDE Plasma Version: 5.13.4
KDE Frameworks Version: 5.48.0
Qt Version: 5.11.1

ADDITIONAL INFORMATION

Fedora 28 x64 KDE spin
Kernel 4.18.11-200.fc28.x86_64
Hardware: HP Envy x360 laptop with AMD Ryzen 5 2500U with Radeon Vega Mobile Graphics (4 core/8 threads)
16 GB RAM
Comment 1 Freek de Kruijf 2019-01-10 11:48:15 UTC
Most likely I do have the same problem.
I have an RSS feed to Linux.com.
I select the entry: (DNS Domain Name Service): A Detailed High Level Overview
I press on the link: Het het hele verhaal
which is pointing to:
https://www.linux.com/learn/dns-domain-name-service-detailed-high-level-overview
After kontact crashes and does nor produce a usable crash report. The report it produces is below:
Application: kontact (5.10.0)

Qt Version: 5.12.0
Frameworks Version: 5.53.0
Operating System: Linux 4.19.11-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
<Vertel ons in detail wat u aan het doen was toen het programma crashte.>

The crash can be reproduced every time.

-- Backtrace:
A useful backtrace could not be generated

Rapporteer naar https://bugs.kde.org/
Comment 2 Christophe Giboudeaux 2019-01-10 16:18:56 UTC
Can be reproduced in master. Running akregator in gdb gives:
#0  0x00007fffee41df1f in QtWebEngineCore::ProfileAdapter::httpUserAgent() const () from /usr/lib64/libQt5WebEngineCore.so.5
#1  0x00007fffee445a98 in QtWebEngineCore::WebContentsAdapter::initialize(content::SiteInstance*) () from /usr/lib64/libQt5WebEngineCore.so.5
#2  0x00007fffee44f438 in ?? () from /usr/lib64/libQt5WebEngineCore.so.5
Comment 3 Christophe Giboudeaux 2019-02-26 08:13:15 UTC
*** Bug 404815 has been marked as a duplicate of this bug. ***
Comment 4 Wolfgang Bauer 2019-02-26 18:15:47 UTC
*** Bug 404765 has been marked as a duplicate of this bug. ***
Comment 5 austin 2019-03-19 16:51:08 UTC
Just to add an observation-

I find that I am much less likely to crash Akregator if I *always* right-click any link that I encounter and hit open in new tab.

Note that the option configure->browser->"open links in new tab instead of new window" doesn't help; I have to right-click -> new tab every time.

But this helps keep Akregator running for me. 

Fedora 29
Akregator
Version 5.10.2
KDE Frameworks 5.55.0
Qt 5.11.3 (built against 5.11.3)
Comment 6 talha.khan1 2019-03-23 21:19:44 UTC
It seems that the latest updates have helped a lot. I haven't experienced crashes when clicking links in Akregator now, but it does crash when I click on a link inside a web page tab in Akregator. Currently here is my system:

Operating System: Fedora 29
KDE Plasma Version: 5.14.5
Qt Version: 5.11.3
KDE Frameworks Version: 5.55.0
Kernel Version: 4.19.15-300.fc29.x86_64
OS Type: 64-bit
Processors: 8 × AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
Memory: 15.4 GiB of RAM

Akregator info:
Version      : 18.12.2
Release      : 1.fc29

qt5-qtwebengine info:
Version      : 5.11.3
Release      : 3.fc29
Comment 7 Wolfgang Bauer 2019-05-21 11:07:59 UTC
*** Bug 407688 has been marked as a duplicate of this bug. ***
Comment 8 Wolfgang Bauer 2019-06-21 06:58:39 UTC
*** Bug 408811 has been marked as a duplicate of this bug. ***
Comment 9 Wolfgang Bauer 2019-07-07 15:48:55 UTC
*** Bug 409572 has been marked as a duplicate of this bug. ***
Comment 10 Pierre Maraval 2019-08-19 23:58:43 UTC
Created attachment 122254 [details]
New crash information added by DrKonqi

kontact (5.12.0) using Qt 5.13.0

- What I was doing when the application crashed:

- I was consulting a newsfeed in Kontact/Akgregator from "Defense News"
- The sum-up of an interesting article shows up
- I click in the browser view to readthe "Complete Story"
- A web page with the requested content opens in a new tab in Akregator
- In this new tab there is a link to a Facebook video
- clicking the link crashes the application (Kontact).

- On the next Kontact/Akregator startup an option is proposed to restore the (Akgregator) session at Akregator startup.
- The bug is reproducible by restoring the session and repeating the steps above.

-- Backtrace (Reduced):
#6  0x00007fb92bd6245e in QtWebEngineCore::ProfileAdapter::httpUserAgent() const () from /usr/lib64/libQt5WebEngineCore.so.5
#7  0x00007fb92bd38fb2 in QtWebEngineCore::WebContentsAdapter::initialize(content::SiteInstance*) () from /usr/lib64/libQt5WebEngineCore.so.5
#8  0x00007fb92bd30500 in QtWebEngineCore::WebContentsDelegateQt::AddNewContents(content::WebContents*, std::unique_ptr<content::WebContents, std::default_delete<content::WebContents> >, WindowOpenDisposition, gfx::Rect const&, bool, bool*) () from /usr/lib64/libQt5WebEngineCore.so.5
#9  0x00007fb92da72d0e in content::WebContentsImpl::ShowCreatedWindow () at ../../3rdparty/chromium/content/browser/web_contents/web_contents_impl.cc:2950
#10 0x00007fb92d77ce5f in base::DispatchToMethodImpl<content::RenderFrameHostImpl*, void (content::RenderFrameHostImpl::*)(int, WindowOpenDisposition, gfx::Rect const&, bool), std::tuple<int, WindowOpenDisposition, gfx::Rect, bool>, 0ul, 1ul, 2ul, 3ul> () at ../../3rdparty/chromium/base/tuple.h:52
Comment 11 Jonáš Vidra 2019-10-08 06:55:08 UTC
Created attachment 123085 [details]
Backtrace generated by the KCrash handler after the segfault

I seem to have the same problem: Akregator crashes when clicking a link in an open webpage. I've attached a backtrace with more information – the build I'm using is optimized with -O2, so not all information is there, but at least it includes line numbers.
Comment 12 Wolfgang Bauer 2019-10-12 16:41:25 UTC
*** Bug 412771 has been marked as a duplicate of this bug. ***
Comment 13 Szőts Ákos 2019-10-17 16:29:40 UTC
Created attachment 123281 [details]
New crash information added by DrKonqi

akregator (5.12.1) using Qt 5.13.1

- What I was doing when the application crashed:

Opened a new tab in Akregator, left-clicked a link on it, then the program crashed.

-- Backtrace (Reduced):
#5  0x00007efbf63c2c4e in QtWebEngineCore::ProfileAdapter::httpUserAgent() const () from /usr/lib64/libQt5WebEngineCore.so.5
#6  0x00007efbf63a0302 in QtWebEngineCore::WebContentsAdapter::initialize(content::SiteInstance*) () from /usr/lib64/libQt5WebEngineCore.so.5
#7  0x00007efbf63947b7 in QtWebEngineCore::WebContentsDelegateQt::AddNewContents(content::WebContents*, std::unique_ptr<content::WebContents, std::default_delete<content::WebContents> >, WindowOpenDisposition, gfx::Rect const&, bool, bool*) () from /usr/lib64/libQt5WebEngineCore.so.5
#8  0x00007efbf80e5c88 in content::WebContentsImpl::CreateNewWindow () at ../../3rdparty/chromium/content/browser/web_contents/web_contents_impl.cc:2831
#9  0x00007efbf7dd7988 in content::RenderFrameHostImpl::CreateNewWindow(mojo::StructPtr<content::mojom::CreateNewWindowParams>, base::OnceCallback<void (content::mojom::CreateNewWindowStatus, mojo::StructPtr<content::mojom::CreateNewWindowReply>)>) () at ../../3rdparty/chromium/content/browser/frame_host/render_frame_host_impl.cc:3823
Comment 14 Wolfgang Bauer 2020-03-23 12:25:29 UTC
*** Bug 419130 has been marked as a duplicate of this bug. ***
Comment 15 Wolfgang Bauer 2020-05-20 07:38:49 UTC
*** Bug 415945 has been marked as a duplicate of this bug. ***
Comment 16 John Scott 2020-06-17 16:26:46 UTC
Created attachment 129456 [details]
New crash information added by DrKonqi

akregator (5.14.1 (20.04.0)) using Qt 5.12.5

I still get this on Debian Bullseye, with Akregator and KF5 at 20.04.1.

The crash *does* happen for me when manually right-clicking and opening in a new tab, i.e. this doesn't seem to mitigate it as prior comments suggested. I was able to reproduce with JavaScript disabled, and also opening in a Background Tab.

What seems to do it for me is clicking a link beneath the title on an /r/netsec post, which you can get the RSS feed like
https://www.reddit.com/r/netsec/.rss

-- Backtrace (Reduced):
#4  0x00007f7b6aceb46e in QtWebEngineCore::ProfileAdapter::httpUserAgent() const () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#5  0x00007f7b6ad178b5 in QtWebEngineCore::WebContentsAdapter::initialize(content::SiteInstance*) () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#6  0x00007f7b6ad1fb8e in QtWebEngineCore::WebContentsDelegateQt::AddNewContents(content::WebContents*, std::unique_ptr<content::WebContents, std::default_delete<content::WebContents> >, WindowOpenDisposition, gfx::Rect const&, bool, bool*) () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#7  0x00007f7b6c740187 in content::WebContentsImpl::CreateNewWindow(content::RenderFrameHost*, int, int, int, content::mojom::CreateNewWindowParams const&, content::SessionStorageNamespace*) () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#8  0x00007f7b6c44d150 in content::RenderFrameHostImpl::CreateNewWindow(mojo::StructPtr<content::mojom::CreateNewWindowParams>, base::OnceCallback<void (content::mojom::CreateNewWindowStatus, mojo::StructPtr<content::mojom::CreateNewWindowReply>)>) () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
Comment 17 John Scott 2020-06-17 16:26:46 UTC
Created attachment 129457 [details]
New crash information added by DrKonqi

akregator (5.14.1 (20.04.0)) using Qt 5.12.5

I still get this on Debian Bullseye, with Akregator and KF5 at 20.04.1.

The crash *does* happen for me when manually right-clicking and opening in a new tab, i.e. this doesn't seem to mitigate it as prior comments suggested. I was able to reproduce with JavaScript disabled, and also opening in a Background Tab.

What seems to do it for me is clicking a link beneath the title on an /r/netsec post, which you can get the RSS feed like
https://www.reddit.com/r/netsec/.rss

-- Backtrace (Reduced):
#4  0x00007f7b6aceb46e in QtWebEngineCore::ProfileAdapter::httpUserAgent() const () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#5  0x00007f7b6ad178b5 in QtWebEngineCore::WebContentsAdapter::initialize(content::SiteInstance*) () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#6  0x00007f7b6ad1fb8e in QtWebEngineCore::WebContentsDelegateQt::AddNewContents(content::WebContents*, std::unique_ptr<content::WebContents, std::default_delete<content::WebContents> >, WindowOpenDisposition, gfx::Rect const&, bool, bool*) () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#7  0x00007f7b6c740187 in content::WebContentsImpl::CreateNewWindow(content::RenderFrameHost*, int, int, int, content::mojom::CreateNewWindowParams const&, content::SessionStorageNamespace*) () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#8  0x00007f7b6c44d150 in content::RenderFrameHostImpl::CreateNewWindow(mojo::StructPtr<content::mojom::CreateNewWindowParams>, base::OnceCallback<void (content::mojom::CreateNewWindowStatus, mojo::StructPtr<content::mojom::CreateNewWindowReply>)>) () at /lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
Comment 18 Don Curtis 2020-10-30 18:08:03 UTC
Created attachment 132893 [details]
New crash information added by DrKonqi

kontact (5.14.2 (20.04.2)) using Qt 5.12.7

Akregator version: 5.14.2 (20.04.2)

- What I was doing when the application crashed:

With Akregator, opened this Linux.com news feed URL:
<https://www.linux.com/news/using-trim-and-discard-with-ssds-attached-to-raid-controllers/>
Then opened this Red Hat URL: <https://www.redhat.com/sysadmin/trim-discard-ssds>
 ** Crash – Kontact crashed but, it was Akregator …

-- Backtrace (Reduced):
#4  QString::isNull (this=0x68) at /usr/include/qt5/QtCore/qstring.h:822
#5  QtWebEngineCore::ProfileAdapter::httpUserAgent (this=0x0) at /usr/src/debug/libqt5-qtwebengine-5.12.7-lp152.2.9.x86_64/src/core/profile_adapter.cpp:298
#6  0x00007f4ff620da78 in QtWebEngineCore::WebContentsAdapter::initialize (this=this@entry=0x560200441210, site=site@entry=0x0) at /usr/src/debug/libqt5-qtwebengine-5.12.7-lp152.2.9.x86_64/src/core/web_contents_adapter.cpp:471
#7  0x00007f4ff620e39c in QtWebEngineCore::WebContentsAdapter::loadDefault (this=this@entry=0x560200441210) at /usr/src/debug/libqt5-qtwebengine-5.12.7-lp152.2.9.x86_64/src/core/web_contents_adapter.cpp:569
#8  0x00007f4ff6218727 in QtWebEngineCore::WebContentsDelegateQt::AddNewContents (this=<optimized out>, source=<optimized out>, new_contents=..., disposition=<optimized out>, initial_pos=..., user_gesture=<optimized out>, was_blocked=0x7fff81f1487f) at /usr/src/debug/libqt5-qtwebengine-5.12.7-lp152.2.9.x86_64/src/core/web_contents_delegate_qt.cpp:234
Comment 19 Colin J Thomson 2021-06-14 19:29:21 UTC
*** This bug has been confirmed by popular vote. ***
Comment 20 Colin J Thomson 2022-03-27 13:08:20 UTC
Created attachment 147763 [details]
Akregator back trace

Still seeing this with:
Operating System: Fedora Linux 35
KDE Plasma Version: 5.24.3
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.2
Kernel Version: 5.16.17-200.fc35.x86_64 (64-bit)

A good example is to click a link say in KDE Reddit to another reddit user or Site and it crashes everytime. Another BT attached as DrKonq said it was useful.