Bug 399568 - Dictionary plasmoid icon broken
Summary: Dictionary plasmoid icon broken
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: Icons (show other bugs)
Version: 5.23.5
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: ---
Assignee: visual-design
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-09 16:11 UTC by al-dy
Modified: 2022-07-15 21:37 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the Dictionary icon (126.39 KB, image/png)
2018-10-09 16:11 UTC, al-dy
Details
screenshot taken on Plasma 5.17 beta (71.20 KB, image/png)
2019-09-20 13:47 UTC, Patrick Silva
Details
broken icon in krunner (49.07 KB, image/png)
2022-05-24 20:30 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description al-dy 2018-10-09 16:11:16 UTC
Created attachment 115522 [details]
Screenshot of the Dictionary icon

SUMMARY

STEPS TO REPRODUCE
Open the plasmoids list and look for the dictionary icon.

OBSERVED RESULT

Is the same icon used by the Oxygen theme but with some graphic problems. It's evident that the pages of the book are out of place.

EXPECTED RESULT

Add an icon using the Breeze aesthetics.

SOFTWARE VERSIONS

KDE Plasma Version: 5.13.5
KDE Frameworks Version: 5.50.5
Qt Version: 5.11.2

ADDITIONAL INFORMATION
I can confirm that the problem is present in Manjaro and Neon.
Comment 1 Scott Harvey 2018-10-09 17:18:17 UTC
Confirmed on openSUSE Tumbleweed.

Looks like the .svg icon file got messed up somehow. 

I don't have the requisite Inkscape skills to fix it, unfortunately.
Comment 2 Noah Davis 2018-10-12 03:27:10 UTC
This is actually part of the kdeplasma-addons product, not Breeze icons. Moved to the correct category
Comment 3 Noah Davis 2018-10-12 03:31:04 UTC
This icon clearly does not match the Breeze icon style, so perhaps the dictionary should be given an entirely new icon?
Comment 4 Nate Graham 2018-10-12 13:43:43 UTC
Agreed.
Comment 5 andreas 2018-10-12 14:05:13 UTC
Whats the icon name?
Comment 6 Kai Uwe Broulik 2018-10-12 14:08:28 UTC
The plasmoid ships its own "accessories-dictionary" svg file but Oxygen has one already. If we added a similar icon in Breeze, we could stop if from shipping its own icon and just use the one on the icon theme.
Comment 7 Patrick Silva 2019-09-20 12:25:59 UTC
This bug is fixed on my system.

Operating System: Arch Linux 
KDE Plasma Version: 5.16.90
KDE Frameworks Version: 5.62.0
Qt Version: 5.13.1
Comment 8 David Edmundson 2019-09-20 12:53:25 UTC
Mine still looks like the initial screenshot
Comment 9 Nate Graham 2019-09-20 13:35:13 UTC
No new icon has been made, so it should still be broken.
Comment 10 Patrick Silva 2019-09-20 13:47:22 UTC
Created attachment 122762 [details]
screenshot taken on Plasma 5.17 beta

Weird. I'm attaching a screenshot. And yes, I use breeze icon theme.
Comment 11 Kai Uwe Broulik 2019-09-20 13:48:10 UTC
Still broken for me on master, though.
Comment 12 Noah Davis 2019-09-20 22:50:05 UTC
(In reply to Patrick Silva from comment #10)
> Created attachment 122762 [details]
> screenshot taken on Plasma 5.17 beta
> 
> Weird. I'm attaching a screenshot. And yes, I use breeze icon theme.

This may be because you have the Oxygen icon theme installed and Breeze inherits from Oxygen on some distros. I can see in your screenshot that the blur effect is being used, even though the Qt SVG renderer does not support blur. This means the SVG has been converted to a PNG.
Comment 13 Noah Davis 2019-09-20 22:54:07 UTC
This is an Oxygen icon and Oxygen icons are meant to be converted to PNGs. Perhaps this icon should be converted to a PNG when the applet is built? That, or the icon should be completely replaced with a Breeze icon. The latter should probably happen eventually, but the former would be enough to close this bug.
Comment 14 Patrick Silva 2022-05-24 20:30:35 UTC
Created attachment 149186 [details]
broken icon in krunner

As seen in the screenshot attache to this comment, Dictionary icon is broken in krunner too.

Operating System: Arch Linux
KDE Plasma Version: 5.24.90
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Graphics Platform: Wayland
Comment 15 Nate Graham 2022-05-24 20:37:54 UTC
It's broken in the icon itself.

Manuel, would you be interested in making a nice new Breeze-style dictionary icon?
Comment 16 ratijas 2022-07-15 21:03:34 UTC
Git commit 0ca1edead879cfa29c72124015a3f08bc9d751d3 by ivan tkachenko.
Committed on 15/07/2022 at 21:03.
Pushed by ratijas into branch 'master'.

Remove clipPath portion of SVG

Not only Qt SVG does not support clipping, but it would also simply draw
a clipping mask as is it were a regular shape!

M  +-    --    applets/dict/sc-apps-accessories-dictionary.svgz

https://invent.kde.org/plasma/kdeplasma-addons/commit/0ca1edead879cfa29c72124015a3f08bc9d751d3
Comment 17 Nate Graham 2022-07-15 21:36:49 UTC
Git commit 3854385a81922824bf7ac3ccf4a544fb943a2b5c by Nate Graham, on behalf of ivan tkachenko.
Committed on 15/07/2022 at 21:36.
Pushed by ngraham into branch 'Plasma/5.25'.

Remove clipPath portion of SVG

Not only Qt SVG does not support clipping, but it would also simply draw
a clipping mask as is it were a regular shape!


(cherry picked from commit 0ca1edead879cfa29c72124015a3f08bc9d751d3)

M  +-    --    applets/dict/sc-apps-accessories-dictionary.svgz

https://invent.kde.org/plasma/kdeplasma-addons/commit/3854385a81922824bf7ac3ccf4a544fb943a2b5c
Comment 18 Nate Graham 2022-07-15 21:37:38 UTC
Git commit 4fae3fa7c9a21d2fc6224ea48e10525330ae46ce by Nate Graham, on behalf of ivan tkachenko.
Committed on 15/07/2022 at 21:37.
Pushed by ngraham into branch 'Plasma/5.24'.

Remove clipPath portion of SVG

Not only Qt SVG does not support clipping, but it would also simply draw
a clipping mask as is it were a regular shape!


(cherry picked from commit 0ca1edead879cfa29c72124015a3f08bc9d751d3)

M  +-    --    applets/dict/sc-apps-accessories-dictionary.svgz

https://invent.kde.org/plasma/kdeplasma-addons/commit/4fae3fa7c9a21d2fc6224ea48e10525330ae46ce