Bug 398663 - Several drop downs show white text on white background when I set breeze dark desktop theme
Summary: Several drop downs show white text on white background when I set breeze dark...
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Plasma
Component: QStyle (show other bugs)
Version: 5.13.90
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 398598 398599 398600 398666 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-15 12:37 UTC by Patrick Silva
Modified: 2018-09-23 21:16 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.14.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-09-15 12:37:51 UTC
Both Arch Linux (plasma 5.14 beta) and neon dev unstable are affected.

The problem affects for example system tray settings, task manager settings, kicker/dashboard settings, digital clock settings, desktop settings and some widgets settings.

The following link contains several screenshots taken on Arch Linux.
http://imgbox.com/g/2KmjC4PTNI
Comment 1 Kai Uwe Broulik 2018-09-17 07:44:13 UTC
I can confirm. Somehow Breeze doesn't style the dropdown properly again :/ That used to work
Comment 2 Hugo Pereira Da Costa 2018-09-17 07:47:48 UTC
(In reply to Kai Uwe Broulik from comment #1)
> I can confirm. Somehow Breeze doesn't style the dropdown properly again :/
> That used to work

Code in breeze with respect to comboboxes has not changed for months. So this must be some chain reaction from another upstream change (Qt, QtQuick controls, whatever).
Comment 3 Kai Uwe Broulik 2018-09-17 07:52:28 UTC
Patch https://phabricator.kde.org/D15568
Comment 4 Kai Uwe Broulik 2018-09-17 08:11:55 UTC
Git commit 3e8eac8fc461e35614c3f297fb1ac99ad1c18e53 by Kai Uwe Broulik.
Committed on 17/09/2018 at 08:11.
Pushed by broulik into branch 'Plasma/5.14'.

Fix finding QtQuick

It is QtQuick_FOUND, not Qt_Quick_FOUND. This broke all special-casings for QtQuick,
such as "drag on empty area" in QtQuick windows and ComboBox popups.
FIXED-IN: 5.14.0

Differential Revision: https://phabricator.kde.org/D15568

M  +2    -2    kstyle/CMakeLists.txt

https://commits.kde.org/breeze/3e8eac8fc461e35614c3f297fb1ac99ad1c18e53
Comment 5 Kai Uwe Broulik 2018-09-17 08:20:40 UTC
*** Bug 398598 has been marked as a duplicate of this bug. ***
Comment 6 Kai Uwe Broulik 2018-09-18 08:26:58 UTC
*** Bug 398666 has been marked as a duplicate of this bug. ***
Comment 7 Patrick Silva 2018-09-23 21:10:27 UTC
*** Bug 398599 has been marked as a duplicate of this bug. ***
Comment 8 Patrick Silva 2018-09-23 21:16:09 UTC
*** Bug 398600 has been marked as a duplicate of this bug. ***