Bug 398400 - Get Involved page available
Summary: Get Involved page available
Status: RESOLVED FIXED
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-08 19:05 UTC by Andrew Crouthamel
Modified: 2018-09-18 20:39 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Crouthamel 2018-09-08 19:05:31 UTC
I noticed through a web search, that there is a Get Involved page, separate from the Wiki one currently linked to.

https://www.kde.org/get-involved

If this is old content, it should be removed, as search engines (DDG) are offering it up as the #1 link.
Comment 1 Albert Astals Cid 2018-09-08 20:37:20 UTC
Removing pages is never a good idea. You end up with broken links and that's bad.
Comment 2 Andrew Crouthamel 2018-09-08 20:41:40 UTC
That's fine, then that URL should have a redirect to the current location which is on the community Wiki. Having duplicate content which is out of date, is not good for web Crawlers, or the people who happen to land on that page like myself.
Comment 3 Albert Astals Cid 2018-09-08 22:41:38 UTC
Which is the url in the community wiki?
Comment 4 Andrew Crouthamel 2018-09-09 03:14:46 UTC
https://community.kde.org/Get_Involved which is the same link the Get Involved button takes you to from kde.org.
Comment 5 Albert Astals Cid 2018-09-18 17:21:33 UTC
Personally i always feel a bit uneasy about doing redirects like that.

I'd like to understand why the wiki was created if we already had a get involved webpage.

Was it because the people writing the wiki didn't know the existing one existed? 
Was it some other reason? 
Also who am I/you to decide the wiki content is better than the other page? Is there an actual consensus on that?
Comment 6 Nate Graham 2018-09-18 17:26:39 UTC
(In reply to Albert Astals Cid from comment #5)
> Was it because the people writing the wiki didn't know the existing one
> existed? 
Not knowing the reason, I suspect this is the case.


> Was it some other reason? 
There is a major advantage to having it a wiki: the barrier to editing it is vastly smaller than for a webpage on kde.org. Even most people with contributor accounts don't have access to the website. As a result...


> Also who am I/you to decide the wiki content is better than the other page?
I can confidently state that the wiki content is now better than the website content, because I and others have been working on improving it for the past year, because it's a wiki. https://www.kde.org/get-involved on the other hand is terribly out of date and lacks most of the information on https://community.kde.org/Get_Involved/. It is not actually a useful source of information.


> Is there an actual consensus on that?
Sounds like we should ask folks and see if we can come to one. :)
Comment 7 Andrew Crouthamel 2018-09-18 18:10:12 UTC
I feel we're going to get sidetracked here, as the issue is relating to an unlinked, dead page. But: 

(In reply to Albert Astals Cid from comment #5)
> Personally i always feel a bit uneasy about doing redirects like that.

Why? It's normal throughout the web.

(In reply to Nate Graham from comment #6)
> > Was it some other reason? 
> There is a major advantage to having it a wiki: the barrier to editing it is
> vastly smaller than for a webpage on kde.org. Even most people with
> contributor accounts don't have access to the website. As a result...

I agree with this, and something I'd like to bring up at a later date is moving other pages that have been left to rot, to Wiki-style for this same reason.
Comment 8 Lydia Pintscher 2018-09-18 19:34:41 UTC
Jep let's change it. Not good to have two. The wiki one is more maintained and seems to have a future.
Comment 9 Nate Graham 2018-09-18 20:19:06 UTC
Cool. Who has the power to do this?

...I guess technically I do since I have write access to the repo backing kde.org. But my web skills are close to non-existent, so someone would have to walk me through the process.
Comment 10 Andrew Crouthamel 2018-09-18 20:27:35 UTC
(In reply to Nate Graham from comment #9)
> Cool. Who has the power to do this?
> 
> ...I guess technically I do since I have write access to the repo backing
> kde.org. But my web skills are close to non-existent, so someone would have
> to walk me through the process.

There a few ways, the most common is with .htaccess such as:

Redirect /get-involved https://community.kde.org/Get_Involved

^ I do not guarantee that is 100% correct, but it is close.
Comment 11 Unknown 2018-09-18 20:34:15 UTC
SVN commit 1524935 by aacid:

Redirect get-involved to https://community.kde.org/Get_Involved



 M  +2 -191    get-involved.php  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1524935
Comment 12 Albert Astals Cid 2018-09-18 20:35:04 UTC
I think it's a very bad idea to move things to the wiki, we have restricted commits right to www for a reason, but oh well, new times :D
Comment 13 Nate Graham 2018-09-18 20:39:08 UTC
Thanks Albert!

New times indeed. :) For what it's worth, so far our new wiki Get Involved page has been a big hit.