Bug 397113 - includeMousePointer on rectangular snapshot when used as a shortcut
Summary: includeMousePointer on rectangular snapshot when used as a shortcut
Status: RESOLVED DUPLICATE of bug 392057
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-03 01:09 UTC by Robert Vanden Eynde
Modified: 2018-08-03 09:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Vanden Eynde 2018-08-03 01:09:26 UTC
The KDE Daemon global shortcuts allow to choose a shortcut for `Take Rectangular Region Screenshot`, it defaults to `Meta+Shift+PrtScr`.

However that takes a screenshot **with** the mouse pointer, how do I disable that?

When I open Spectacle, the _includeMousePointer_ is not checked, so apparently that's a different setting.

Apparently this [commit](https://github.com/KDE/spectacle/commit/e6f41e4e712065aee6416da79f4d538f74116a58) seems to say it's possible to do so but I don't know how.

I've posted as [SO question](https://stackoverflow.com/questions/51641850/kde-spectacle-includemousepointer-on-rectangular).
Comment 1 Christoph Feck 2018-08-03 02:09:16 UTC
I answered there, but I am not sure why you added a ticket in bugzilla. Do you request the default to be changed? Or a secondary hotkey with the different behaviour? Please clarify.
Comment 2 Robert Vanden Eynde 2018-08-03 02:27:44 UTC
I saw the option "Include mouse pointer" in KSpectacle so I assumed the DBus command would use that (not sure everybody would do that because one must know that the Shortcut is related to Spectacle).

If this is the only argument, as you mentionned, having a secondary hotkey with different behavior would be useful.

If the DBus command has many, like, includeWindowDecorations for "WindowUnderCursor" having an hotkey per combinaison would polute the available keyboard list (2 booleans = 4 possiblities).

Or maybe add a generic way to provide arguments to commands. That's also something I want in Kate's shortcuts, but that's way more general than Spectacle.
Comment 3 Robert Vanden Eynde 2018-08-03 02:57:55 UTC
I wrote "KSpectacle" I'm tired... However, if we have two different hot keys, the default (the Meta+Shift+PrtScr) should be no mouse pointer IMHO, I think it's what people want generally (the mouse is often hiding important stuff). Maybe that will break someone's workflow since this setting exist for 2 years.
Comment 4 null 2018-08-03 09:35:08 UTC
Thanks for your comments and the initial investigation, let's continue in Bug 392057.

As for hiding the cursor by default: I agree, and opened Bug 397121.

*** This bug has been marked as a duplicate of bug 392057 ***