Bug 397106 - Some icons look fuzzy when I set 1.2 as display scaling factor
Summary: Some icons look fuzzy when I set 1.2 as display scaling factor
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: Master
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords:
: 399335 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-02 20:08 UTC by Patrick Silva
Modified: 2019-03-14 13:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.57


Attachments
screenshot (141.43 KB, image/png)
2018-08-02 20:08 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-08-02 20:08:28 UTC
Created attachment 114274 [details]
screenshot

See the screenshot taken on Arch Linux, plasma 5.13.3.
User manager and power saving icons look fuzzy.
Comment 1 Nate Graham 2018-08-09 22:30:39 UTC
Can reproduce. If you look closely, the circular icons in the sidebar have the same glitches.
Comment 2 Patrick Silva 2019-01-17 20:54:43 UTC
bug persists in plasma 5.15 beta.

Operating System: Arch Linux 
KDE Plasma Version: 5.14.90
KDE Frameworks Version: 5.54.0
Qt Version: 5.12.0
Comment 3 Marco Martin 2019-03-11 12:51:21 UTC
problem is if it scales a non integer number of pixels, by definition things cannot be pixel perfect.
in the end the choice is between having a sharp but glitchy image or a bit blurry.
Comment 4 Nate Graham 2019-03-11 13:40:15 UTC
Given those options, blurry is much better than glitchy IMO.
Comment 5 Marco Martin 2019-03-11 15:47:59 UTC
Turns out it's a double scaling in kiconloader, after all.
(not that after the patch the icons are still not perfect because they can't, but immensely better)
https://phabricator.kde.org/D19686
Comment 6 Kai Uwe Broulik 2019-03-13 11:20:56 UTC
Git commit 89344923c00b7bc502f5c24be50027b457d82177 by Kai Uwe Broulik.
Committed on 13/03/2019 at 11:20.
Pushed by broulik into branch 'master'.

Fix padding icon that doesn't exactly match the requested size

The size we get already takes into account scaling, so we end up creating a pixmap
whose size was scaled twice and then had the view scale it down again.

Reviewed-By: Marco Martin
Related: bug 396990

M  +1    -1    src/kiconengine.cpp

https://commits.kde.org/kiconthemes/89344923c00b7bc502f5c24be50027b457d82177
Comment 7 Nate Graham 2019-03-14 13:48:03 UTC
*** Bug 399335 has been marked as a duplicate of this bug. ***