Bug 396909 - On Windows there is no support for installing debug packages
Summary: On Windows there is no support for installing debug packages
Status: RESOLVED NOT A BUG
Alias: None
Product: drkonqi
Classification: Applications
Component: general (show other bugs)
Version: 5.13.3
Platform: Other Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks: 373980 380136
  Show dependency treegraph
 
Reported: 2018-07-27 15:23 UTC by Ralf Habacker
Modified: 2019-06-18 15:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Habacker 2018-07-27 15:23:07 UTC
drkonqi has support for installing debug packages if the generated backtrace is incomplete caused by missing symbols.

On linux this support is provided by a shell script, which runs a distribution specific package manager, which is called to install missing debug packages.

On windows there is currently no support to install debug packages.
Comment 1 Harald Sitter 2019-06-18 15:35:28 UTC
It's not actually a shell script, it's just by default named that way. The distributor, on windows I would argue that is the person creating the exe, is responsible for adding a suitable helper that takes care of the debug package installation.