Bug 396829 - Horizontal and Vertical Mirror Tool Not Working For Only Basic-1 Brush
Summary: Horizontal and Vertical Mirror Tool Not Working For Only Basic-1 Brush
Status: RESOLVED DUPLICATE of bug 372636
Alias: None
Product: krita
Classification: Unclassified
Component: Tools (show other bugs)
Version: 4.1.1
Platform: Other Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-24 22:00 UTC by hiddenblade1013
Modified: 2018-07-25 07:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
_Basic-1 brush not working with horizontal mirror tool (319.48 KB, image/png)
2018-07-24 22:10 UTC, hiddenblade1013
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hiddenblade1013 2018-07-24 22:00:34 UTC
All other brushes work except for Basic-1 from Krita 4 Default Resources for both Horizontal and Vertical Mirror Tool.
Comment 1 hiddenblade1013 2018-07-24 22:10:09 UTC
Created attachment 114101 [details]
_Basic-1 brush not working with horizontal mirror tool
Comment 2 hiddenblade1013 2018-07-24 22:30:34 UTC
I was told I am not being clear so I'll try to describe the problem better.




_Basic-1 brush from Krita_4_Default_Resources can make marks on plain canvas.

When using either Horizontal and Vertical Mirror Tool, marks are made only on one side of the mirror tool instead of the expected both sides. No marks are being mirrored.

When using any other brush besides _Basic-1, marks are mirrored and works as expected.

Horizontal and Vertical Mirror Tool does not mirror marks made from _Basic-1 brush from Krita_4_Default_Resources.

Therefore, I think there is a bug with the Horizontal and Vertical Mirror Tool not working for only _Basic-1 brush from Krita_4_Default_Resources.
Comment 3 Halla Rempt 2018-07-25 07:00:22 UTC
This brush uses the quick brush engine which currently doesn't support mirroring because the added complexity would impact the performance of the brush engine. It's not really a bug: it's something we haven't implemented. See https://bugs.kde.org/show_bug.cgi?id=372636

*** This bug has been marked as a duplicate of bug 372636 ***