Bug 396815 - Transform mask in file from 2.9.11 not loaded properly in 4.1.1
Summary: Transform mask in file from 2.9.11 not loaded properly in 4.1.1
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: File formats (show other bugs)
Version: 4.1.1
Platform: Other Linux
: NOR major
Target Milestone: ---
Assignee: Dmitry Kazakov
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-07-24 13:16 UTC by animtim
Modified: 2019-04-23 20:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description animtim 2018-07-24 13:16:51 UTC
When loading a file made with Krita 2.9.11 that uses transform masks, the effect of the masks is lost.

Test file:
http://timotheegiet.com/kritaB/08-comicsB.zip

Open test file. Content of the clone layers should be moved in the third case, but they are not. You can even see how it should look with the thumbnail preview of the file in file explorer...

Doing it again in Krita 4.1.1 (using transform tool to make a simple move) and saving, it loads fine after.

So it looks like a change in file format not handled properly, or something like that.
Comment 1 Halla Rempt 2018-09-01 13:08:54 UTC
Yes, I can confirm the issue.
Comment 2 Dmitry Kazakov 2019-04-23 20:54:46 UTC
Git commit d82899b0d67e217442ae5ace88e760a6eded907f by Dmitry Kazakov.
Committed on 23/04/2019 at 20:40.
Pushed by dkazakov into branch 'master'.

Fix loading of pre-krita-4.0 transform masks

We should be more tolerant for older configs that do not have
all the options we support.

M  +13   -6    plugins/tools/tool_transform2/tool_transform_args.cc

https://invent.kde.org/kde/krita/commit/d82899b0d67e217442ae5ace88e760a6eded907f