Bug 396800 - Gwenview crashes when open Pentax camera images
Summary: Gwenview crashes when open Pentax camera images
Status: RESOLVED DUPLICATE of bug 382842
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 18.04.3
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-23 18:18 UTC by Bernhard Lindner
Modified: 2018-07-23 22:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example image (100.95 KB, image/jpeg)
2018-07-23 18:20 UTC, Bernhard Lindner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Lindner 2018-07-23 18:18:29 UTC
When opening jpg images from my Penteax K-X camera, Gwenview crashes with the message "Speicherzugriffsfehler" (Memory access error).

This does not happen with other images.

I have attached an example image.
Comment 1 Bernhard Lindner 2018-07-23 18:20:12 UTC
Created attachment 114088 [details]
Example image
Comment 2 null 2018-07-23 21:54:03 UTC
Thanks for the report. I downloaded your example image and opened it in Gwenview, which worked just fine on Tumbleweed and Kubuntu 18.04.

On a Neon installation (based on Ubuntu 16.04) I indeed get it to crash:

#0  0x00007ffff14cbb4f in Exiv2::ExifData::findKey(Exiv2::ExifKey const&) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#1  0x00007ffff1515f81 in Exiv2::Internal::PentaxMakerNote::printShutterCount(std::ostream&, Exiv2::Value const&, Exiv2::ExifData const*) ()
   from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#2  0x00007ffff73c1623 in Exiv2::operator<<(std::ostream&, Exiv2::Metadatum const&) () from lib/x86_64-linux-gnu/libgwenviewlib.so.5
#3  0x00007ffff73c30f3 in void Gwenview::ImageMetaInfoModelPrivate::fillExivGroup<Exiv2::ExifData, std::_List_const_iterator<Exiv2::Exifdatum> >(QModelIndex const&, Gwenview::MetaInfoGroup*, Exiv2::ExifData const&) () from lib/x86_64-linux-gnu/libgwenviewlib.so.5
#4  0x00007ffff73c0821 in Gwenview::ImageMetaInfoModel::setExiv2Image(Exiv2::Image const*) ()
   from lib/x86_64-linux-gnu/libgwenviewlib.so.5
#5  0x00007ffff737a74d in Gwenview::Document::setExiv2Image(std::auto_ptr<Exiv2::Image>) ()
   from lib/x86_64-linux-gnu/libgwenviewlib.so.5
#6  0x00007ffff7377aea in Gwenview::AbstractDocumentImpl::setDocumentExiv2Image(std::auto_ptr<Exiv2::Image>) ()
   from lib/x86_64-linux-gnu/libgwenviewlib.so.5
#7  0x00007ffff7382df7 in Gwenview::LoadingDocumentImpl::slotMetaInfoLoaded() () from lib/x86_64-linux-gnu/libgwenviewlib.so.5
#8  0x00007ffff7440957 in Gwenview::LoadingDocumentImpl::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) ()
   from lib/x86_64-linux-gnu/libgwenviewlib.so.5
#9  0x00007ffff3717b89 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007ffff3526a71 in QFutureWatcherBase::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007ffff4e9c29c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#12 0x00007ffff4ea3917 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#13 0x00007ffff36eae38 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007ffff36eda3e in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007ffff37425c3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007fffebca0197 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007fffebca03f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007fffebca049c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007ffff3741bcf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007fffdee30c11 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#21 0x00007ffff36e91ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007ffff36f22d4 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x000000000046a0d7 in main ()

However, the crash happens in Exiv2, and most likely is already fixed upstream (http://dev.exiv2.org/issues/0001283 looks like it). Try upgrading once Neon switches its base to Ubuntu 18.04.
Comment 3 Christoph Feck 2018-07-23 22:33:18 UTC

*** This bug has been marked as a duplicate of bug 382842 ***