Bug 396788 - Cage transform GUI paints wrongly (and sometimes crashes) when creating a cage
Summary: Cage transform GUI paints wrongly (and sometimes crashes) when creating a cage
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools/Transform (show other bugs)
Version: 4.1.1
Platform: Other Linux
: NOR crash
Target Milestone: ---
Assignee: Scott Petrovic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-23 08:56 UTC by Dmitry Kazakov
Modified: 2018-07-24 07:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (65.08 KB, image/png)
2018-07-23 08:56 UTC, Dmitry Kazakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Kazakov 2018-07-23 08:56:00 UTC
Created attachment 114081 [details]
Screenshot

1) Create image 
2) Paint something
3) Activate Transform Tool -> Cage
4) Start creating a cage

Some points of the cage are painted in negative infinity and connect weirdly


Video:
https://vk.com/ilovefreeart?z=video156827233_456239788%2F2348b4a43d2fa1af8b%2Fpl_post_-38024296_16144
Comment 1 Dmitry Kazakov 2018-07-23 13:10:33 UTC
Assigned to Scott :)
Comment 2 Scott Petrovic 2018-07-23 13:12:00 UTC
confirmed. This is caused by some recent warp rendering changes. That logic must be spilling over to the cage transform mode for some reason.
Comment 3 Scott Petrovic 2018-07-24 01:14:37 UTC
Git commit 4b4c5ce7afed68d0115ceb9e883f48442140ba13 by Scott Petrovic.
Committed on 24/07/2018 at 01:14.
Pushed by scottpetrovic into branch 'master'.

M  +2    -0    plugins/tools/tool_transform2/kis_cage_transform_strategy.cpp
M  +12   -2    plugins/tools/tool_transform2/kis_warp_transform_strategy.cpp
M  +6    -0    plugins/tools/tool_transform2/kis_warp_transform_strategy.h

https://commits.kde.org/krita/4b4c5ce7afed68d0115ceb9e883f48442140ba13
Comment 4 Halla Rempt 2018-07-24 07:59:20 UTC
Git commit 5aac27570ce311e5b3f43560a460bc42decc881a by Boudewijn Rempt, on behalf of Scott Petrovic.
Committed on 24/07/2018 at 07:16.
Pushed by rempt into branch 'krita/4.1'.

M  +2    -0    plugins/tools/tool_transform2/kis_cage_transform_strategy.cpp
M  +12   -2    plugins/tools/tool_transform2/kis_warp_transform_strategy.cpp
M  +6    -0    plugins/tools/tool_transform2/kis_warp_transform_strategy.h

https://commits.kde.org/krita/5aac27570ce311e5b3f43560a460bc42decc881a