Bug 396672 - Krita does not save metadata of imported images
Summary: Krita does not save metadata of imported images
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: File formats (show other bugs)
Version: git master (please specify the git hash!)
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: amyspark
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-19 16:43 UTC by Danas
Modified: 2021-08-17 22:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danas 2018-07-19 16:43:02 UTC
Hello, 

I am experiencing an issue with Krita, it doesn't save and keep meta data like exif information in imported layers.  The best example is when you want to add some art to photos, you can make a complicated edit of image, save it to krita document file (*.kra) and when you open the kra file again, no metadata is present in layers that should have it. But metadata is very useful to keep your stuff organized and it would be great if Krita would keep each layer metada all the time for as many modifications of krita document as needed.
Comment 1 David REVOY 2018-07-19 17:17:26 UTC
Hi Danas,
In my point of view, not importing/merging metadatas of imported graphics is not an issue if you create artwork from scratch. It's more like a feature (if you import a texture in a artwork, you don't want the metadatas of the texture ; author, software, date to merge with your artwork). 

It is the same if you add art to a photo; It become a Krita artwork without any relation to the previous photo. I wouldn't like if I export the document as JPG to get the original metadatas of the photo exported with my JPG.

Krita still preserves metadatas of JPG and PNG afaik if you open them, edit on fly and overwrite. If you need to merge art in a photo and keep metadatas while keeping a *.kra file with layers; I would suggest to export the JPG by overwriting the original with a copy/paste, to preserve the metadatas of the original photos.

But because your request is in related to photo editing feature that doesn't really help to create artwork from start to end (scope of Krita development) I would propose to close this bug report as 'Invalid'.
Comment 2 Danas 2018-07-19 18:28:19 UTC
Hi David, 

I kind of wanted to slip without someone noticing photo editing (which seems to be a dark horse here). Sneaky me :) but Krita makes a very fine image editing in various applications in addition to digital painting. And I believe it is a bug for Krita to loose layer information in kra files once you close and open it later. It something like text editor that would loose numbers or certain phrases once you reopen your novel document to continue on writing.  It's not a feature request for a new feature for photo editing stuff, but asking for a function to work properly. If that is possible to do. When it comes to exporting images without metadata  you just don't merge the layers and even when you do merge,  krita asks  what you wanna do with metadata. By the looks of it, it seems that krita prioritizes no inclusion of metada, but was designed to support it in a basic way. So I still think that this is a valid request. Otherwise all the wonderful animation functionality of Krita could be questioned...why dp needs animation then?  why not stop at digital painting only? why does it need to have a text tool?  This is my point of view. Metadata support was there for a very long time and I see no reason to eliminate functionality or ignore that something is not working quite right. Or is photography not a form of art that could adapt digital painting for artistic purposes?
Comment 3 Danas 2018-07-19 18:28:58 UTC
Hi David, 

I kind of wanted to slip without someone noticing photo editing (which seems to be a dark horse here). Sneaky me :) but Krita makes a very fine image editing in various applications in addition to digital painting. And I believe it is a bug for Krita to loose layer information in kra files once you close and open it later. It something like text editor that would loose numbers or certain phrases once you reopen your novel document to continue on writing.  It's not a feature request for a new feature for photo editing stuff, but asking for a function to work properly. If that is possible to do. When it comes to exporting images without metadata  you just don't merge the layers and even when you do merge,  krita asks  what you wanna do with metadata. By the looks of it, it seems that krita prioritizes no inclusion of metada, but was designed to support it in a basic way. So I still think that this is a valid request. Otherwise all the wonderful animation functionality of Krita could be questioned...why dp needs animation then?  why not stop at digital painting only? why does it need to have a text tool?  This is my point of view. Metadata support was there for a very long time and I see no reason to eliminate functionality or ignore that something is not working quite right. Or is photography not a form of art that could adapt digital painting for artistic purposes?
Comment 4 Halla Rempt 2018-09-01 13:20:34 UTC
Hm, we actually have code that should save and load the metadata for a layer in the .kra file. It looks like that has broken, so I can confirm the bug. Since it's a dataloss problem and a regression, I'll mark it as release blocker and critical.
Comment 5 Halla Rempt 2018-09-11 08:52:32 UTC
Actually, it looks like the original jpeg metadata is kept associated with the layer. The dublin core metadata is also saved, as can be seen in the list -- like dc:author. However, the dublin core widget isn't filled correctly.
Comment 6 Halla Rempt 2018-09-11 12:43:50 UTC
Git commit 41c6768017d96f808a843cbaebdafb2447d5c809 by Boudewijn Rempt.
Committed on 11/09/2018 at 12:42.
Pushed by rempt into branch 'master'.

metadata: Show the first element of an array

The editor plugin is still horribly broken, with dates not
working, bools not working, but now at least a string one
has entered is shown again.

M  +9    -4    plugins/extensions/metadataeditor/kis_entry_editor.cc
M  +2    -2    plugins/extensions/metadataeditor/kis_entry_editor.h
M  +10   -7    plugins/extensions/metadataeditor/kis_meta_data_editor.cc

https://commits.kde.org/krita/41c6768017d96f808a843cbaebdafb2447d5c809
Comment 7 Halla Rempt 2018-09-15 09:11:10 UTC
Git commit b006afcbfa31084b612d566d341472b1d2d7e670 by Boudewijn Rempt.
Committed on 15/09/2018 at 09:08.
Pushed by rempt into branch 'krita/4.1'.

metadata: Show the first element of an array

The editor plugin is still horribly broken, with dates not
working, bools not working, but now at least a string one
has entered is shown again.

M  +9    -4    plugins/extensions/metadataeditor/kis_entry_editor.cc
M  +2    -2    plugins/extensions/metadataeditor/kis_entry_editor.h
M  +10   -7    plugins/extensions/metadataeditor/kis_meta_data_editor.cc

https://commits.kde.org/krita/b006afcbfa31084b612d566d341472b1d2d7e670
Comment 8 amyspark 2021-08-17 22:07:38 UTC
As of 5b50fe4281fa8fdbc3cbd260074e9af6d7d5c19c, Krita stores and displays the imported image's metadata in the Background layer.