Bug 396545 - Dolphin crashes when
Summary: Dolphin crashes when
Status: RESOLVED DUPLICATE of bug 380114
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 17.12.3
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-07-15 20:32 UTC by Eugen Stepanov
Modified: 2018-08-02 18:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugen Stepanov 2018-07-15 20:32:48 UTC
Application: dolphin (17.12.3)

Qt Version: 5.9.5
Frameworks Version: 5.44.0
Operating System: Linux 4.15.0-23-generic x86_64
Distribution: Ubuntu 18.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Renamed files .cbr in Konsole and converted JPG images into PDF file in Konsole 
- Unusual behavior I noticed:
About 100 empty system messages (notifications) were hanging at the bottom right corner KDE Panel and on Dolphin icon in Panel
- Custom settings of the application:
usual

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc4bf6c36c0 (LWP 5371))]

Thread 2 (Thread 0x7fc4a5d0e700 (LWP 5373)):
#0  0x00007fc4bef3bbf9 in __GI___poll (fds=0x7fc49801ac30, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fc4b1e91439 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc4b1e9154c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc4b914f90b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fc4b90f49ea in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fc4b8f1322a in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fc4b95ccd45 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007fc4b8f1816d in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fc4b40026db in start_thread (arg=0x7fc4a5d0e700) at pthread_create.c:463
#9  0x00007fc4bef4888f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fc4bf6c36c0 (LWP 5371)):
[KCrash Handler]
#6  0x0000557cab623ec0 in  ()
#7  0x00007fc4baf99606 in  () at /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#8  0x00007fc4baf996a9 in  () at /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#9  0x00007fc4b912319b in QObjectPrivate::deleteChildren() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007fc4b912c9cb in QObject::~QObject() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007fc4baf73579 in  () at /usr/lib/x86_64-linux-gnu/libKF5Notifications.so.5
#12 0x00007fc4bee6a041 in __run_exit_handlers (status=0, listp=0x7fc4bf212718 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true, run_dtors=run_dtors@entry=true) at exit.c:108
#13 0x00007fc4bee6a13a in __GI_exit (status=<optimized out>) at exit.c:139
#14 0x00007fc4bee48b9e in __libc_start_main (main=0x557ca92db730, argc=1, argv=0x7ffd71c3e188, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd71c3e178) at ../csu/libc-start.c:344
#15 0x0000557ca92db76a in _start ()

Reported using DrKonqi
Comment 1 Julian Steinmann 2018-07-16 07:18:34 UTC
Hello and thanks for reporting this crash! The backtrace you provided is sadly incomplete, so it is hard for us to triage this bug. Please install the debug symbols for libkf5notifications and try to reproduce this crash again. Thanks!
Comment 2 Christoph Feck 2018-08-02 18:47:48 UTC

*** This bug has been marked as a duplicate of bug 380114 ***