Bug 396479 - Smudging is weakened inside selections
Summary: Smudging is weakened inside selections
Status: RESOLVED DUPLICATE of bug 423851
Alias: None
Product: krita
Classification: Unclassified
Component: Brush engines (show other bugs)
Version: 4.1.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-13 15:22 UTC by Kapyia
Modified: 2020-07-27 15:03 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Comparison of smudge with and without selection (198.75 KB, image/png)
2018-07-13 15:22 UTC, Kapyia
Details
Video demonstration (2.18 MB, video/webm)
2018-07-13 16:00 UTC, Kapyia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kapyia 2018-07-13 15:22:04 UTC
Created attachment 113920 [details]
Comparison of smudge with and without selection

Painting with a Color Smudging brush preset inside of a selected area appears to weaken the Smudge Length
Comment 1 Halla Rempt 2018-07-13 15:43:28 UTC
I cannot reproduce this. Did you change any other settings (size of the brush, preset settings, flow, opacity)? Could you attach a kra file to make it easier to reproduce?
Comment 2 Kapyia 2018-07-13 16:00:38 UTC
Created attachment 113921 [details]
Video demonstration

I haven't made any changes to the brush preset, it is the default one pre-packaged with Krita. I could attach a .kra file if you'd like, but to me this problem isn't bound to any specific project and happens with all smudge brush presets.

It might be worth mentioning that I'm not using Instant Preview mode, and I tried turning off Canvas Graphics Acceleration as well, but the problem persists.
Comment 3 Jaime Torres 2018-10-01 08:36:45 UTC
I can reproduce it with 4.2.0-pre-alpha (git ae5e111).
My simplest steps to reproduce it:

Create a new 16-bit integer/channel document.
Draw a big enough rectangle with a red color.
Select Wet Circle brush
Change to a blue color 
Change its Opacity to 40%
Draw over the rectangle
Select All
Draw over the rectangle
The resulting lines are not the same.
Comment 4 wolthera 2020-07-27 15:03:32 UTC
Marking this as duplicate of the newer bug as that one's assigned.

*** This bug has been marked as a duplicate of bug 423851 ***