Bug 396473 - Can't enable blur or configure translucency
Summary: Can't enable blur or configure translucency
Status: RESOLVED FIXED
Alias: None
Product: yakuake
Classification: Applications
Component: general (show other bugs)
Version: 3.0.5
Platform: Archlinux Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-13 12:36 UTC by Christian Muehlhaeuser
Modified: 2019-07-09 19:02 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Muehlhaeuser 2018-07-13 12:36:25 UTC
While it's working correctly in Konsole, I can't configure the translucency or enable a blurred background in Yakuake at all.

Instead under "Appearance" of the profile settings, I get a warning message instead of the configuration widgets:

"Konsole was started before desktop effects were enabled. You need to restart Konsole to see transparent background."
Comment 1 Nate Graham 2018-07-13 16:01:41 UTC
Does the blur appear if you reboot your machine?
Comment 2 Christoph Feck 2018-07-13 16:56:06 UTC
See bug 395520.
Comment 3 Christian Muehlhaeuser 2018-07-13 17:04:00 UTC
Sorry Nate, should have added that: no, this warning message always appears, even after rebooting / starting a new session.
Comment 4 Nate Graham 2018-07-13 17:06:47 UTC

*** This bug has been marked as a duplicate of bug 395520 ***
Comment 5 Nate Graham 2018-07-13 21:07:40 UTC
From Bug 395520:
> 18.04+ has a call apps can make to determine if the profile has blur
> enabled.  As I understand it, the app is responsible for enabling blur in
> its code (mainwindow), not konsole kpart.

Looks like Yakuake needs this done?