Bug 396472 - "Start in same directory as current tab" has no effect
Summary: "Start in same directory as current tab" has no effect
Status: RESOLVED FIXED
Alias: None
Product: yakuake
Classification: Applications
Component: general (show other bugs)
Version: 3.0.5
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
: 307441 412392 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-13 12:33 UTC by Christian Muehlhaeuser
Modified: 2020-03-12 02:17 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 20.04.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Muehlhaeuser 2018-07-13 12:33:36 UTC
While it's working fine in Konsole itself, the same profile setting in Yakuake has no effect. New tabs always open in my home directory.
Comment 1 Andrew Smith 2018-08-13 11:53:49 UTC
I can confirm this too. Same profile in Konsole and the checkbox setting is followed but inside Yakuake new tabs/splits always start in my home folder. Setting an initial folder doesn't make a difference either.
Comment 2 Andrew Smith 2018-08-13 13:26:33 UTC
I've spent a bit of time getting things set up so I could compile Yakuake and going back to v3.0 and the setting didn't work then either. Looking at the git blame it looks like the line of code for opening the terminal at the path hasn't really changed in 11 years so I'm really not sure what to do now

[0] is where the new terminal sessions are opening (or at least, if I change that to `rootPath()` all new terminals open `/`). Checking the previous version it used `KUser` to get the home path but still basically did the same thing. Before that the last change was 11 years ago :-/

I've tried to have a look through the Konsole source to see how that does it but I'm not finding anything that looks useful (I don't know any KDE code really so I'm just trying to search for something similar).


0: https://github.com/KDE/yakuake/blame/master/app/terminal.cpp#L89
Comment 3 linken.dinh 2018-11-04 11:24:36 UTC
There is a link to a github commit which seemed to have fixed it in the past:

https://mail.kde.org/pipermail/konsole-devel/2013-June/021269.html

https://github.com/panzi/Yakuake/commit/e5668b2ce4d142070631374306667f3e3a3d8369
Comment 4 Christian Muehlhaeuser 2020-03-10 14:58:52 UTC
*** Bug 412392 has been marked as a duplicate of this bug. ***
Comment 5 Christian Muehlhaeuser 2020-03-10 15:03:19 UTC
*** Bug 307441 has been marked as a duplicate of this bug. ***