Bug 396236 - wayland: systemsettings changing order and scale of monitor is not persisted between reboots
Summary: wayland: systemsettings changing order and scale of monitor is not persisted ...
Status: RESOLVED WORKSFORME
Alias: None
Product: KScreen
Classification: Plasma
Component: common (show other bugs)
Version: 5.13.2
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-06 07:37 UTC by Miroslav Spehar
Modified: 2022-12-08 05:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Spehar 2018-07-06 07:37:13 UTC
Monitor settings (left-right position) and scaling is not persisted between reboots.

Solved in archlinux in Bug 389490, but still there on opensuse tw.

Reported in opensuse bugzilla here:
https://bugzilla.opensuse.org/show_bug.cgi?id=1096815
Comment 1 Unknown 2018-07-23 08:33:19 UTC
Rotation is not persistent too.

I have one monitor 90 rotated counterclockwise and it gets reset after reboot.
Comment 2 Unknown 2018-07-23 08:35:37 UTC
I don't think it is related to wayland.
I don't use wayland and I have noticed this bug more than a year ago.
Comment 3 Unknown 2018-07-23 11:39:01 UTC
Workaround for rotation:

Add this to startup script:

xrandr --output <output> --rotate left
Comment 4 Nate Graham 2022-11-08 20:22:41 UTC
Thank you for the bug report. Unfortunately we were not able to get to it yet. Can we ask you to please see if you can reproduce the issue with Plasma 5.25 or 5.26?

If you can, please change the status to CONFIRMED when replying. Thanks a lot!
Comment 5 Bug Janitor Service 2022-11-23 05:15:25 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Bug Janitor Service 2022-12-08 05:14:59 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!