Bug 396015 - Texture Layer Style does not work
Summary: Texture Layer Style does not work
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Layer Stack (show other bugs)
Version: 4.1.0 alpha
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Gernene Tan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-30 11:19 UTC by 616057653
Modified: 2019-04-16 08:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screen shot of using the layerstyle (75.51 KB, image/jpeg)
2018-06-30 11:19 UTC, 616057653
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 616057653 2018-06-30 11:19:53 UTC
Created attachment 113656 [details]
screen shot of using the layerstyle

layer style texture cannot work. 图层样式 纹理 没有效果。 
There is no fx button after using [layer syle-texture].And the layer didn't change at all.
Comment 1 Halla Rempt 2018-07-10 14:06:45 UTC
I can confirm the issue
Comment 2 Gernene Tan 2019-04-08 06:36:27 UTC
(In reply to Boudewijn Rempt from comment #1)
> I can confirm the issue

Hello! Is this a Windows-specific issue? I'm trying to reproduce this, but I can't seem to locate the missing fx button. Do you know how I can make that appear?
Comment 3 616057653 2019-04-08 07:16:54 UTC
You tick [layer style] --> [texture] , nothing changed.
I found another bug: saving a jpg picture as gif  cannot work.
Comment 4 Gernene Tan 2019-04-08 14:54:34 UTC
(In reply to 616057653 from comment #3)
> You tick [layer style] --> [texture] , nothing changed.
> I found another bug: saving a jpg picture as gif  cannot work.

Thanks for clarifying.
Also, this issue can be replicated on Linux Ubuntu 18.04
Comment 5 Gernene Tan 2019-04-09 01:13:27 UTC
Update:
Turns out that this is not a bug. Both "Texture" and "Contour" layer styles are only applied to canvas when "Bevel and Emboss" is active.
Comment 6 Gernene Tan 2019-04-09 01:14:00 UTC
I am currently working to make the GUI a bit clearer.
Comment 7 616057653 2019-04-09 07:00:28 UTC
(In reply to Gernene Tan from comment #5)
> Update:
> Turns out that this is not a bug. Both "Texture" and "Contour" layer styles
> are only applied to canvas when "Bevel and Emboss" is active.

Wow, You are right! It worked when I ticked  "Bevel and Emboss" . Thanks you very much.
Comment 8 Halla Rempt 2019-04-16 08:07:06 UTC
Git commit 767bb9907e14951ae9228a1eb6e0d9af56bb9e3f by Boudewijn Rempt, on behalf of Gener ne.
Committed on 16/04/2019 at 08:06.
Pushed by rempt into branch 'master'.

Disable "Contour" and "Texture" by default and re-enables them when "Bevel and Emboss" is applied.

M  +30   -0    libs/ui/dialogs/kis_dlg_layer_style.cpp
M  +2    -0    libs/ui/dialogs/kis_dlg_layer_style.h
M  +8    -2    libs/ui/layerstyles/wdglayerstyles.ui

https://commits.kde.org/krita/767bb9907e14951ae9228a1eb6e0d9af56bb9e3f