Bug 395972 - Slideshow makes desktop excruciatingly slow
Summary: Slideshow makes desktop excruciatingly slow
Status: RESOLVED DUPLICATE of bug 371455
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.12.5
Platform: Gentoo Packages Linux
: NOR major
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-28 17:43 UTC by JohnRCox@comcast.net
Modified: 2020-01-02 17:20 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description JohnRCox@comcast.net 2018-06-28 17:43:53 UTC
I have an amd64 system on gentoo running KDE 5.12.5 with dual monitors. Displaying a slideshow makes the Application Menu run so slow that it is unusable. It takes minutes to go from selecting the icon to the Application menu appearing and more minutes for an application to run. Applications seem to run at normal speed and switching between running applications is normal. This fails with one slideshow or two running.
Comment 1 Nate Graham 2018-06-28 19:20:30 UTC
A slideshow for the wallpaper? Or somewhere else? And can you confirm that removing the slideshow improved the speed? Also, what Qt version are you using?
Comment 2 JohnRCox@comcast.net 2018-06-28 20:34:16 UTC
I did a Configure Desktop/Wallpaper Type/Slideshow and configured a directory of .jpeg files. The slowdown was immediate. I have not taken away the slideshow except by resetting KDE. I did this by deleting all the plasma* files in ~/.local/share/ Once I did this all applications ran at their usual speed.

My impression of the slowdown was that the slideshow might be happening and only leaving a small time interval for the Application Menu to run.

Trying to remove the desktop slideshow to see if the system speeds up again would be an interesting test but it would be excruciating to try to set up. Let me know if this is an important question and I will see if I can do it.

Qt version is 5.9.4
Comment 3 Nate Graham 2018-06-28 21:14:19 UTC
Reminds me a bit of Bug 368838 which was fixed in Qt 5.11, but that was about memory usage and didn't cause issues immediately.

Please do remove the slideshow and see if that fixes the issue. When you blow away ~/.local/share/plasma*, that's resetting a lot more than just the slideshow, so it's hard to tell what the actual culprit is.
Comment 4 JohnRCox@comcast.net 2018-06-28 21:40:53 UTC
I changed the background to slideshow and selected a directory full of jpeg files. The slowdown happened as soon as I did the OK on the dialog box. Picture changing was considerably slower than the 10 seconds selected--closer to a minute.

Reselecting the Configure Desktop takes 2 or 3 pictures to happen. This seems consistent in that it never happens right away. I wonder if it is losing the action. Selecting any menu item on the dialog box also takes several pictures to happen.

I selected the Astronomy Picture of the Day. It came up as soon as I hit the OK button and the Application Menu was back at normal speed.

Hope this helps.
Comment 5 Nate Graham 2018-06-28 21:42:53 UTC
Thanks a lot for the information, that does help.
Comment 6 thierry.rouillon 2019-12-29 17:03:25 UTC
I confirm this defect. When the computer starts there is a blockage (black screen) before installing the desktop. This problem is not blocking because after 3 minutes, the office is installed.
If I take a still image, the problem goes away.
Comment 7 Nate Graham 2020-01-02 17:20:38 UTC

*** This bug has been marked as a duplicate of bug 371455 ***