Bug 395963 - No Hidden Files icon in Dolphin
Summary: No Hidden Files icon in Dolphin
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: icons (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: pinheiro
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-28 12:54 UTC by Greg Lepore
Modified: 2018-06-28 22:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of toolbar showing lack of Hidden Files icon. (27.62 KB, image/png)
2018-06-28 12:54 UTC, Greg Lepore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Lepore 2018-06-28 12:54:44 UTC
Created attachment 113624 [details]
Screenshot of toolbar showing lack of Hidden Files icon.

I'm sure this has been noticed before, but I can't find a bug specific to this issue. There appears to not be an icon associated with the Hidden Files toolbar option in Dolphin when using the Oxygen icon theme.

Is this something that should be reported upstream?
Comment 1 Nate Graham 2018-06-28 21:10:41 UTC
Yep, confirmed.

This seems to be because Dolphin uses the "visibility" icon for this, which is present in Breeze, but not Oxygen. It uses "Hint" for the hidden state, which in Oxygen is a symlink to layer-visible-off. It might be appropriate to symlink "visibility" to "layer-visible-on".

Here's a patch that does that: https://phabricator.kde.org/D13786
Comment 2 Nate Graham 2018-06-28 22:05:36 UTC
Git commit 93aae9335b392356c02e30aabd3143bc4060e78e by Nathaniel Graham.
Committed on 28/06/2018 at 22:02.
Pushed by ngraham into branch 'master'.

Show an icon for hidden files in Dolphin

Summary:
Dolphin uses the `hint` icon for invisible hidden files and the `visibility` icon for shown hidden files.

Everything works fine with Breeze icons, but with Oxygen, there is no `visibility` icon. The `hint` icon is symlinked to something appropriate, so this patch just symlinks `visibility` to the its companion icon.
FIXED-IN 5.48

Test Plan: {F5968440}

Reviewers: #dolphin, aacid, cfeck

Reviewed By: cfeck

Subscribers: cfeck, kde-frameworks-devel

Tags: #frameworks

Differential Revision: https://phabricator.kde.org/D13786

A  +1    -0    16x16/actions/visibility.png
A  +1    -0    22x22/actions/visibility.png
A  +1    -0    32x32/actions/visibility.png
A  +1    -0    48x48/actions/visibility.png

https://commits.kde.org/oxygen-icons5/93aae9335b392356c02e30aabd3143bc4060e78e