Bug 395473 - The "Minimize all Windows" applet should restores all windows on second stroke by click or by keyboard shortcut
Summary: The "Minimize all Windows" applet should restores all windows on second strok...
Status: RESOLVED DUPLICATE of bug 413044
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Show Desktop/Minimize All (show other bugs)
Version: 5.13.0
Platform: openSUSE RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-16 04:07 UTC by uRohan
Modified: 2020-02-26 16:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description uRohan 2018-06-16 04:07:41 UTC
OS: openSUSE Tumbleweed 20180613
KDE Frameworks Version: 5.46.0
Qt Version: 5.11.0
Kernel Version: 4.16.12-3-default
OS Type: 64-bit


Reproducible: Always

Steps to Reproduce:

Make sure System Settings - Windows Management - KWin Scripts - MinimizeAll script and associated keyboard shortcut is disabled or even was not appointed.

1. Add "Minimize all Windows" applet to the Desktop or to the Plasma Panel.
2. Open "Minimize all Windows" context menu and click "Configure Minimize all Windows".
3. Add keyboard shortcut (for example Meta+Shift+D).
4. Use "Minimize all Windows" applet by a keyboard shortcut or by clicking on it's icon located on the Desktop or the Default Plasma Panel.

Actual Results:
The "Minimize all Windows" applet only minimizes windows but does not restore them by the second click or keyboard shortcut.

Expected Results:
The "Minimize all Windows" applet should restore windows by the second click or by keyboard shortcut.
Comment 1 uRohan 2018-06-16 06:04:08 UTC
Probably the enabling of the option "Keep window thumbnails - Always" (System Settings - Display and Monitor - Compositor - Keep window thumbnails - Always) is the trigger of this error (or misbehavior).
Comment 2 Nate Graham 2020-02-26 16:19:43 UTC

*** This bug has been marked as a duplicate of bug 413044 ***