Bug 395175 - support opening multiple files from "File->Open" dialog
Summary: support opening multiple files from "File->Open" dialog
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: 1.4.1
Platform: Archlinux Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2018-06-09 11:41 UTC by Lukas Sabota
Modified: 2018-06-25 15:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Sabota 2018-06-09 11:41:33 UTC
Okular supports opening multiple files at the same time on the command line by specifying multiple PDF files as arguments.  However, if one wants to open multiple PDFs within the Okular QT GUI, one must open each one one at a time through the Open dialog since it is a single-file open dialog.
I suggest this Open dialog be changed to support multiple files so that users can quickly open a set of PDFs in a directory without having to run okular from the terminal.
Comment 1 Christoph Feck 2018-06-21 01:11:39 UTC
Interesting. The code actually loops over all selected files, but the dialog is not executed in a mode where multiple files are allowed. This might just be a porting regression, and should be easy to fix.

See https://cgit.kde.org/okular.git/tree/shell/shell.cpp#n476
Comment 2 Oliver Sander 2018-06-21 19:48:27 UTC
It is easy to fix:

  https://phabricator.kde.org/D13667
Comment 3 Lukas Sabota 2018-06-22 23:52:47 UTC
https://phabricator.kde.org/D13667 works for me
Comment 4 Oliver Sander 2018-06-25 15:14:12 UTC
Git commit 862b2ab6647e49b141ea7e9197f295bc5e220720 by Oliver Sander.
Committed on 25/06/2018 at 15:11.
Pushed by sander into branch 'master'.

Allow to select more than one file in the 'open file' dialog

Differential Revision: https://phabricator.kde.org/D13667

M  +1    -0    shell/shell.cpp

https://commits.kde.org/okular/862b2ab6647e49b141ea7e9197f295bc5e220720