Bug 394786 - [Wayland] New blur effect shows weird background glitches
Summary: [Wayland] New blur effect shows weird background glitches
Status: RESOLVED DUPLICATE of bug 393723
Alias: None
Product: kwin
Classification: Unclassified
Component: wayland-generic (show other bugs)
Version: 5.12.90
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-28 10:00 UTC by tromzy
Modified: 2018-06-21 13:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Wallpaper (2.09 MB, image/png)
2018-05-28 10:00 UTC, tromzy
Details
Wrong blur effect (1.69 MB, image/png)
2018-05-28 10:00 UTC, tromzy
Details
kde-blur-issue-plasma-5.13 (2.64 MB, image/png)
2018-06-14 16:27 UTC, Miroslav Spehar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tromzy 2018-05-28 10:00:17 UTC
Created attachment 112921 [details]
Wallpaper

On Plasma 5.13 beta, on Wayland, the new blur effect does not work correctly. I attached 2 screenshots : one showing my current wallpaper, and the other one with Konsole with a transparent background and the new blur effect applied : we can see that it does not correctly blurs what's beneath the Konsole window, showing strange artifacts instead.
Comment 1 tromzy 2018-05-28 10:00:52 UTC
Created attachment 112922 [details]
Wrong blur effect
Comment 2 Miroslav Spehar 2018-06-14 16:27:08 UTC
Created attachment 113318 [details]
kde-blur-issue-plasma-5.13

same thing happens on release 5.13

i have dual screen setup where left screen is standard dpi (and it blurs things properly), but the right one is hidpi and this one is not rendering properly.
Comment 3 tromzy 2018-06-21 13:09:37 UTC
On Plasma 5.13.1, the issue seems to be solved. If anyone can confirm...
Comment 4 tromzy 2018-06-21 13:11:02 UTC
It seems to be the same bug as this one : https://bugs.kde.org/show_bug.cgi?id=393723

Which has been fixed for 5.13.1. Closing this bug report now.
Comment 5 Vlad Zahorodnii 2018-06-21 13:15:49 UTC
tromzy@free.fr: Just to be sure, are you using a HiDPI display?
Comment 6 tromzy 2018-06-21 13:17:22 UTC
No ; I'm using my laptop monitor (1366x768) attached to an external FullHD monitor (1920x1080).
Comment 7 Vlad Zahorodnii 2018-06-21 13:24:42 UTC

*** This bug has been marked as a duplicate of bug 393723 ***