Bug 394587 - Marble 2.2.20 (17.12.1): Cannot parse osm nominatim result
Summary: Marble 2.2.20 (17.12.1): Cannot parse osm nominatim result
Status: RESOLVED DUPLICATE of bug 394517
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-23 02:04 UTC by Kevin Kofler
Modified: 2018-05-23 02:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Kofler 2018-05-23 02:04:47 UTC
Nominatim searches in Marble 2.2.20 (KDE Applications 17.12.1) recently stopped working. On the console, the warning:
Cannot parse osm nominatim result
is printed. No results appear.

I suspect that this is because http://nominatim.openstreetmap.org/ now redirects to https://nominatim.openstreetmap.org/ , so the URL fragment at OsmNominatimSearchRunner.cpp:53 needs to be updated. And you probably also want to fix your code to support redirects.
Comment 1 Kevin Kofler 2018-05-23 02:08:51 UTC

*** This bug has been marked as a duplicate of bug 394517 ***