Bug 394525 - Adblock filters don't work
Summary: Adblock filters don't work
Status: REPORTED
Alias: None
Product: akregator
Classification: Applications
Component: internal browser (show other bugs)
Version: 5.8.1
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-21 16:40 UTC by wincak
Modified: 2021-04-03 13:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wincak 2018-05-21 16:40:35 UTC
Adblocking rules don't seem to be blocking anything.
Ads are still shown. Adding blocklists or manually adding block rules don't hide anything.

Reproducibility: Always

How to reproduce
1) Add a feed to Akregator (for example http://feeds.arstechnica.com/arstechnica/index/)
2) Click on random article and open it in a new tab
3) Ads are visible
4) Enable Adblock plugin in Webengine plugins configuration and check "Hide filtered elements"
5) Add blocklists (for example EasyList)
6) Restart Akregator
7) Ads are still visible
8) Add manual filter using address of one of the ads (for example https://track.adform.net/*)
9) Restart Akregator
10) Ads are still visible

This happens with other sites as well.
Comment 1 Laurent Montel 2019-05-31 05:25:05 UTC
Is it still valid in last version ? I fixed it in 5.11.x
Comment 2 wincak 2019-06-05 18:27:18 UTC
(In reply to Laurent Montel from comment #1)
> Is it still valid in last version ? I fixed it in 5.11.x

No, blocking still does not work for me in version 5.11.x (KDE Neon now). No change.

But thanks for working on it, Akregator sure as hell needs some fixes.
Comment 3 wincak 2021-04-03 13:03:01 UTC
After switching to different RSS reader a long time ago I just tried again on current KDE Neon and adblock is still broken. Also some of the blocklists offered in the combobox are not available anymore and it does not seem to be possible to add new ones - only manually add rules or import blocklists from local files.