Bug 394503 - Mouse pointer captured too late when using "Include mouse pointer" with "Rectangular Region" capture mode
Summary: Mouse pointer captured too late when using "Include mouse pointer" with "Rect...
Status: RESOLVED FIXED
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-21 05:12 UTC by Arfrever Frehtes Taifersar Arahesis
Modified: 2018-12-17 15:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 19.04.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis 2018-05-21 05:12:44 UTC
When "Include mouse pointer" is used with "Rectangular Region" capture mode, then location and appearance of mouse pointer are captured at the time of pressing Enter, but the reasonable behavior would be to capture these data at the time of capturing other part of screenshot.
Comment 1 null 2018-05-21 06:46:29 UTC
Thanks for the report. The problem is already being worked on in https://phabricator.kde.org/D12626 (might take a while, though).
Comment 2 Nate Graham 2018-12-17 15:30:49 UTC
Git commit 958fdc0a2532e30e7edfd1ec71f63fd3c87b5d35 by Nate Graham, on behalf of Ambareesh  Balaji.
Committed on 17/12/2018 at 15:30.
Pushed by ngraham into branch 'master'.

Port QML Rectangle cropper to QWidget + QPainter

Summary:
1. Port QML canvas based screenshot cropper to QWidget + QPainter based cropper
2. Fix minor bugs with cropper while porting, like system font not being set for size indicator
3. "Include mouse pointer" setting now blends the cursor into the screenshot right away, letting the user see it while cropping, rather than blending it in after cropping

Before:
{F5830086}
{F5830115}
After:
{F5830100}
{F5830117}
Related: bug 374009

Test Plan: Compare with original cropper and check if I missed something

Reviewers: #spectacle, broulik, ngraham, alexeymin

Reviewed By: #spectacle, broulik, ngraham, alexeymin

Subscribers: alexeymin, kpiwowarski, broulik, sharvey, guotao, ngraham, rkflx, #spectacle

Tags: #spectacle

Differential Revision: https://phabricator.kde.org/D12626

M  +0    -1    src/CMakeLists.txt
M  +3    -3    src/Gui/KSMainWindow.cpp
M  +3    -7    src/PlatformBackends/X11ImageGrabber.cpp
M  +1    -1    src/PlatformBackends/X11ImageGrabber.h
D  +0    -615  src/QuickEditor/EditorRoot.qml
D  +0    -7    src/QuickEditor/QmlResources.qrc
M  +711  -89   src/QuickEditor/QuickEditor.cpp
M  +94   -16   src/QuickEditor/QuickEditor.h
D  +0    -360  src/QuickEditor/SelectionRectangle.qml

https://commits.kde.org/spectacle/958fdc0a2532e30e7edfd1ec71f63fd3c87b5d35