Bug 394211 - Nested file layers are not supported
Summary: Nested file layers are not supported
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Layer Stack (show other bugs)
Version: 4.0.3
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-13 19:03 UTC by alina.christenbury
Modified: 2018-06-05 15:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The image(s) I'm struggling with, CRABGINEERING.kra is the main one, and I'm having trouble smoothly editing crab-tutorial.kra (1.24 MB, application/x-7z-compressed)
2018-05-13 19:03 UTC, alina.christenbury
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alina.christenbury 2018-05-13 19:03:37 UTC
Created attachment 112624 [details]
The image(s) I'm struggling with, CRABGINEERING.kra is the main one, and I'm having trouble smoothly editing crab-tutorial.kra

So, I've made several file layers out of a base painting, an ocean scene, and then referenced them across different paintings, like a single school composed of smaller fish which are themselves also file layers, but every time I try to save one of the middle file layers it can't find the smaller individual fish images and asks for every single one of the references. Every time. It's really obnoxious

It looks for a path in my Temp user folder, but they're all stored in the same base folder with the main painting because multiple middle-man paintings use them. Manually loading them works, but it's a bit frustrating, especially since it asks me to manually load them every time and doesn't appear to save the path it's been given.
Comment 1 Halla Rempt 2018-06-05 14:15:54 UTC
Hi Alina,

I can confirm the bug. I suspect the issue is that the file layers are all .kra files.
Comment 2 Halla Rempt 2018-06-05 14:22:53 UTC
Or rather, it breaks on having .kra files that contain file layers.
Comment 3 Halla Rempt 2018-06-05 14:23:46 UTC
*** Bug 386515 has been marked as a duplicate of this bug. ***
Comment 4 Halla Rempt 2018-06-05 14:33:35 UTC
Git commit 6828f33fe3e92fd4ca151bd44ce1886118d01ed6 by Boudewijn Rempt.
Committed on 05/06/2018 at 14:32.
Pushed by rempt into branch 'krita/4.0'.

Do not allow .kra files as file layers

Nesting .kra files is dangerous, since a .kra file can contain
file layers itself, which is not supported.
Related: bug 386515, bug 325686

M  +4    -1    libs/ui/dialogs/kis_dlg_file_layer.cpp

https://commits.kde.org/krita/6828f33fe3e92fd4ca151bd44ce1886118d01ed6
Comment 5 Halla Rempt 2018-06-05 14:33:41 UTC
Git commit 40a1a0c0999a20744ae08244df10b679f172b724 by Boudewijn Rempt.
Committed on 05/06/2018 at 14:33.
Pushed by rempt into branch 'master'.

Do not allow .kra files as file layers

Nesting .kra files is dangerous, since a .kra file can contain
file layers itself, which is not supported.
Related: bug 386515, bug 325686
(cherry picked from commit 6828f33fe3e92fd4ca151bd44ce1886118d01ed6)

M  +4    -1    libs/ui/dialogs/kis_dlg_file_layer.cpp

https://commits.kde.org/krita/40a1a0c0999a20744ae08244df10b679f172b724
Comment 6 alina.christenbury 2018-06-05 15:10:10 UTC
Nice, thanks!