Bug 394072 - Assigning a Color to a Frame in the Animation Timeline Is Broken (Right Click Menu Inconsistency)
Summary: Assigning a Color to a Frame in the Animation Timeline Is Broken (Right Click...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Animation (show other bugs)
Version: 4.0.2
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Dmitry Kazakov
URL:
Keywords: investigated, regression, triaged
Depends on:
Blocks:
 
Reported: 2018-05-10 09:37 UTC by Bollebib
Modified: 2018-09-24 07:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bollebib 2018-05-10 09:37:18 UTC
in 4.0.2 assigning a color to a frame in timeline is broken,it does not work.
Comment 1 Dmitry Kazakov 2018-05-12 09:53:02 UTC
Hi, Bollebib!

I cannot reproduce this bug in by 4.0 build :( Are you really sure the bug is present?
Comment 2 Halla Rempt 2018-05-12 10:13:09 UTC
I cannot reproduce this in 4.0.3
Comment 3 Bollebib 2018-07-01 12:54:21 UTC
I reopened this

i'm now in 4.1 , i ave since i made this bug 2 or 3 times removed kritarc


it took only 2 hours or so for me to notice while initially i could color frames again, i cant color them anymore,again.

the bug is back and i dont know what triggers it

I cant keep removing kritarc.
Comment 4 wolthera 2018-07-02 10:09:04 UTC
could you like, attach the faulty kritarc next time? Then we can figure out what is causing it.
Comment 5 Bollebib 2018-08-13 13:22:43 UTC
Using a mouse seems to be the solution


after that my stylus can change the color again,and if it locks i use a mouse to unlock it again



15:15:46 - Wolthera_laptop: Bollebib: have you tried setting them with a regular mouse?
15:15:55 - Wolthera_laptop: maybe the widget is just not cooperating.
Comment 6 Eoin O'Neill 2018-09-16 04:02:58 UTC
Application Version: Master Branch
System: Ubuntu 18.04 bionic

So I believe I have confirmed your problem but would also like to specify what exactly is happening. Basically, most right click menus in Krita (and other QT applications) allow you to hold down the right click button and release to select an option. While this works for most options Krita's drop down menus, it does not work with frame color selection in the animation timeline. I believe this must be what you are experiencing and why the issue is so intermittent.

Right-mouse release needs to be added to the frame color selection widget to make it consistent with other right click menu options.
Comment 7 Dmitry Kazakov 2018-09-21 09:30:25 UTC
Git commit 66500f84dea377a3221768148006c4616e5a1ded by Dmitry Kazakov.
Committed on 21/09/2018 at 09:29.
Pushed by dkazakov into branch 'master'.

Make color label selector handle mouse release events

Qt supports hold+release context menu actions. We should also
support that in our own widget.

M  +9    -5    libs/ui/widgets/kis_color_label_selector_widget.cpp

https://commits.kde.org/krita/66500f84dea377a3221768148006c4616e5a1ded
Comment 8 Dmitry Kazakov 2018-09-21 09:39:03 UTC
Git commit 37bc6c6686a17cf0a1cf463c9595a865d8f1b203 by Dmitry Kazakov.
Committed on 21/09/2018 at 09:38.
Pushed by dkazakov into branch 'master'.

Use user-selected color label for the auto-created animation frames

M  +2    -1    libs/image/kis_transaction_data.cpp

https://commits.kde.org/krita/37bc6c6686a17cf0a1cf463c9595a865d8f1b203
Comment 9 Halla Rempt 2018-09-24 07:25:05 UTC
Git commit 2078af01bb8eae2257cf0dd04fe9cc983e462af7 by Boudewijn Rempt, on behalf of Dmitry Kazakov.
Committed on 24/09/2018 at 07:05.
Pushed by rempt into branch 'krita/4.1'.

Use user-selected color label for the auto-created animation frames

M  +2    -1    libs/image/kis_transaction_data.cpp

https://commits.kde.org/krita/2078af01bb8eae2257cf0dd04fe9cc983e462af7
Comment 10 Halla Rempt 2018-09-24 07:25:07 UTC
Git commit 85683e361572a9331a2d254b51f5f9b68f66b395 by Boudewijn Rempt, on behalf of Dmitry Kazakov.
Committed on 24/09/2018 at 07:05.
Pushed by rempt into branch 'krita/4.1'.

Make color label selector handle mouse release events

Qt supports hold+release context menu actions. We should also
support that in our own widget.

M  +9    -5    libs/ui/widgets/kis_color_label_selector_widget.cpp

https://commits.kde.org/krita/85683e361572a9331a2d254b51f5f9b68f66b395