Bug 393959 - Ark should check if there is sufficient free space available in destination before start extraction
Summary: Ark should check if there is sufficient free space available in destination b...
Status: RESOLVED FIXED
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 20.04.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Elvis Angelaccio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-07 15:09 UTC by Patrick Silva
Modified: 2022-06-09 18:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.08


Attachments
error message when Ark interrupts extraction because destination is full (36.54 KB, image/png)
2018-05-07 15:09 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2018-05-07 15:09:25 UTC
Created attachment 112472 [details]
error message when Ark interrupts extraction because destination is full

When files extraction is interrupted after a while because destination is full, Ark shows an error message not clear about the problem: "Failed to open file for writing..." (screenshot).
I think Ark should check if free space in destination is sufficient before start the files extraction.
Comment 1 Elvis Angelaccio 2018-05-07 20:10:29 UTC
Yep, this is in the todo list. See https://phabricator.kde.org/T1876

(Patches welcome!)
Comment 2 Nicolas Fella 2021-12-10 12:22:44 UTC
*** Bug 427252 has been marked as a duplicate of this bug. ***
Comment 3 Elvis Angelaccio 2022-06-09 17:46:24 UTC
Git commit 75ee205a779a13f536186720295cae71f130c4a6 by Elvis Angelaccio, on behalf of Tomaz  Canabrava.
Committed on 09/06/2022 at 17:46.
Pushed by elvisangelaccio into branch 'master'.

Block extraction if there's no space left

This works only on the BatchExtract, that's triggered by the
right click menu in dolphin. If the final size of the file
to be uncompressed is bigger than the free space on a folder
or device, quit with an error.

M  +5    -0    kerfuffle/archiveentry.cpp
M  +1    -0    kerfuffle/archiveentry.h
M  +17   -10   kerfuffle/archiveinterface.cpp
M  +6    -0    kerfuffle/archiveinterface.h
M  +24   -0    kerfuffle/jobs.cpp
M  +0    -2    plugins/libarchive/readonlylibarchiveplugin.h

https://invent.kde.org/utilities/ark/commit/75ee205a779a13f536186720295cae71f130c4a6