Bug 393344 - Pixel Brush Line Tool produces jaggies on perfect 45 degree angles
Summary: Pixel Brush Line Tool produces jaggies on perfect 45 degree angles
Status: RESOLVED DUPLICATE of bug 387242
Alias: None
Product: krita
Classification: Unclassified
Component: Brush engines (show other bugs)
Version: 4.0.1
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-20 15:24 UTC by Thomas Giles
Modified: 2018-04-20 15:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Demonstration of 45 degree lines (814 bytes, image/png)
2018-04-20 15:24 UTC, Thomas Giles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Giles 2018-04-20 15:24:55 UTC
Created attachment 112142 [details]
Demonstration of 45 degree lines

Steps to reproduce:
1. Use "Pixel Brush" and the Line Tool.
2. Click and hold. Then hold shift and drag out a 45 degree angle.
3. Release.

Actual Results:
The resulting line tends to have random jaggies along the line. (See the attached example.) On rare occasions the line is perfect, though I haven't been able to nail down exactly what triggers this.

Expected Results:
Neat corner-to-corner pixels making up a line.
Comment 1 Scott Petrovic 2018-04-20 15:28:03 UTC

*** This bug has been marked as a duplicate of bug 387242 ***