Bug 393016 - kmail regression: message structure panel gone
Summary: kmail regression: message structure panel gone
Status: RESOLVED DUPLICATE of bug 387931
Alias: None
Product: kmail2
Classification: Unclassified
Component: UI (show other bugs)
Version: Git (master)
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-11 17:39 UTC by Anguo
Modified: 2018-04-12 04:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anguo 2018-04-11 17:39:41 UTC
I recently upgraded from kde-apps/kmail-17.08.3 to kde-apps/kmail-17.12.3. Since then I have been looking for the message structure panel (giving the choice to view selected emails as HTML, if applicable). I wondered why it had suddenly gone, and I was looking for the appropriate setting.

Searching online, I found a copy of the kmail handbook of an older version (2013-12-12 KDE 4.12) which describes exactly what seems to have disappeared since kmail 17.12:

3.1 The Main Window

If you prefer to view your email in HTML format instead of plain text (Default) click on the bar located on the left hand side of the pane. The text on the bar will inform you which view you are in. If this bar is missing you can enable it in the Settings → Configure KMail... dialog, from there you want the Message Window tab, and select Show HTML status bar

...
For complex messages you can show the structure of the message by selecting View → Show Message Structure, this will show in the message structure viewer below the preview pane.

All the UI and configuration elements mentionned in bold above seem to have disappeared.

Same but with better formatting:
http://linux.overshoot.tv/ticket/16721
Comment 1 Laurent Montel 2018-04-12 04:45:15 UTC

*** This bug has been marked as a duplicate of bug 387931 ***