Bug 392544 - Akregator crashes at start
Summary: Akregator crashes at start
Status: RESOLVED DUPLICATE of bug 392478
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-03-30 23:12 UTC by Roland Hautz
Modified: 2018-04-27 01:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Hautz 2018-03-30 23:12:12 UTC
Application: akregator (5.7.3)
 (Compiled from sources)
Qt Version: 5.9.4
Frameworks Version: 5.44.0
Operating System: Linux 4.15.13-gentoo x86_64
Distribution: "Gentoo Base System release 2.4.1"

-- Information about the crash:
There were a few gentoo Plasma package updates recently, but akregator was not among them.

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ffff7f23840 (LWP 4837))]

Thread 4 (Thread 0x7fffb0ff9700 (LWP 4857)):
#0  0x00007ffff3e1dc55 in __GI___poll (fds=0x7fff74004db0, nfds=1, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fffec22e091 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fff74004db0, timeout=<optimized out>, context=0x7fff74000bf0) at /var/tmp/portage/dev-libs/glib-2.52.3/work/glib-2.52.3/glib/gmain.c:4271
#2  g_main_context_iterate (context=context@entry=0x7fff74000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /var/tmp/portage/dev-libs/glib-2.52.3/work/glib-2.52.3/glib/gmain.c:3967
#3  0x00007fffec22e1ac in g_main_context_iteration (context=0x7fff74000bf0, may_block=may_block@entry=1) at /var/tmp/portage/dev-libs/glib-2.52.3/work/glib-2.52.3/glib/gmain.c:4033
#4  0x00007ffff479c37b in QEventDispatcherGlib::processEvents (this=0x7fff74000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007ffff4746cfa in QEventLoop::exec (this=this@entry=0x7fffb0ff8d30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007ffff4592a7a in QThread::exec (this=this@entry=0x7ffff62f5d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:515
#7  0x00007ffff607fd15 in QDBusConnectionManager::run (this=0x7ffff62f5d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#8  0x00007ffff4597120 in QThreadPrivate::start (arg=0x7ffff62f5d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:368
#9  0x00007fffee2f193a in start_thread (arg=0x7fffb0ff9700) at pthread_create.c:465
#10 0x00007ffff3e2961f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fff8ffff700 (LWP 4856)):
#0  0x00007fffee2f882d in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55555580c490) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55555580c440, cond=0x55555580c468) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55555580c468, mutex=0x55555580c440) at pthread_cond_wait.c:655
#3  0x00007fffb861441b in cnd_wait (mtx=0x55555580c440, cond=0x55555580c468) at /var/tmp/portage/media-libs/mesa-18.0.0/work/mesa-18.0.0/include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x55555587fb10) at /var/tmp/portage/media-libs/mesa-18.0.0/work/mesa-18.0.0/src/util/u_queue.c:255
#5  0x00007fffb8614137 in impl_thrd_routine (p=<optimized out>) at /var/tmp/portage/media-libs/mesa-18.0.0/work/mesa-18.0.0/include/c11/threads_posix.h:87
#6  0x00007fffee2f193a in start_thread (arg=0x7fff8ffff700) at pthread_create.c:465
#7  0x00007ffff3e2961f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fffbc75c700 (LWP 4838)):
#0  0x00007fffee2f882d in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55555579c830) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55555579c7e0, cond=0x55555579c808) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55555579c808, mutex=0x55555579c7e0) at pthread_cond_wait.c:655
#3  0x00007fffbd1eaa9b in cnd_wait (mtx=0x55555579c7e0, cond=0x55555579c808) at /var/tmp/portage/media-libs/mesa-18.0.0/work/mesa-18.0.0/include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x55555579cd30) at /var/tmp/portage/media-libs/mesa-18.0.0/work/mesa-18.0.0/src/util/u_queue.c:255
#5  0x00007fffbd1ea7b7 in impl_thrd_routine (p=<optimized out>) at /var/tmp/portage/media-libs/mesa-18.0.0/work/mesa-18.0.0/include/c11/threads_posix.h:87
#6  0x00007fffee2f193a in start_thread (arg=0x7fffbc75c700) at pthread_create.c:465
#7  0x00007ffff3e2961f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7ffff7f23840 (LWP 4837)):
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#7  0x00007ffff3d5eae7 in __GI_abort () at abort.c:90
#8  0x00007fffe4792be5 in base::debug::BreakDebugger() () from /usr/lib64/libQt5WebEngineCore.so.5
#9  0x00007fffe47a58c5 in logging::LogMessage::~LogMessage() () from /usr/lib64/libQt5WebEngineCore.so.5
#10 0x00007fffe43b04eb in content::ZygoteHostImpl::LaunchZygote(base::CommandLine*, base::ScopedGeneric<int, base::internal::ScopedFDCloseTraits>*) () from /usr/lib64/libQt5WebEngineCore.so.5
#11 0x00007fffe43af5a6 in content::ZygoteCommunication::Init() () from /usr/lib64/libQt5WebEngineCore.so.5
#12 0x00007fffe43afb4e in content::CreateZygote() () from /usr/lib64/libQt5WebEngineCore.so.5
#13 0x00007fffe405c3a5 in content::BrowserMainLoop::EarlyInitialization() () from /usr/lib64/libQt5WebEngineCore.so.5
#14 0x00007fffe405f8b2 in content::BrowserMainRunnerImpl::Initialize(content::MainFunctionParams const&) () from /usr/lib64/libQt5WebEngineCore.so.5
#15 0x00007fffe3ea6d74 in QtWebEngineCore::WebEngineContext::WebEngineContext (this=0x555555a7a560) at /var/tmp/portage/dev-qt/qtwebengine-5.9.4/work/qtwebengine-opensource-src-5.9.4/src/core/web_engine_context.cpp:460
#16 0x00007fffe3ea8055 in QtWebEngineCore::WebEngineContext::current () at /var/tmp/portage/dev-qt/qtwebengine-5.9.4/work/qtwebengine-opensource-src-5.9.4/src/core/web_engine_context.cpp:227
#17 0x00007fffe3e3d5d3 in QtWebEngineCore::BrowserContextAdapter::defaultContext () at /var/tmp/portage/dev-qt/qtwebengine-5.9.4/work/qtwebengine-opensource-src-5.9.4/src/core/browser_context_adapter.cpp:189
#18 0x00007ffff1cd7ead in QWebEngineProfile::defaultProfile () at api/qwebengineprofile.cpp:584
#19 0x00007ffff1cde4b9 in QWebEngineSettings::defaultSettings () at api/qwebenginesettings.cpp:131
#20 0x00007fffb2c832ae in Akregator::Part::initFonts (this=this@entry=0x555555982e50) at /var/tmp/portage/kde-apps/akregator-17.12.3/work/akregator-17.12.3/src/akregator_part.cpp:728
#21 0x00007fffb2c85d1c in Akregator::Part::Part (this=this@entry=0x555555982e50, parentWidget=parentWidget@entry=0x555555793130, parent=parent@entry=0x555555793130, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /var/tmp/portage/kde-apps/akregator-17.12.3/work/akregator-17.12.3/src/akregator_part.cpp:189
#22 0x00007fffb2c89051 in KPluginFactory::createPartInstance<Akregator::Part> (parentWidget=0x555555793130, parent=0x555555793130, args=...) at /usr/include/KF5/KCoreAddons/kpluginfactory.h:501
#23 0x00007ffff633aa29 in KPluginFactory::create (this=this@entry=0x555555a7b430, iface=0x7ffff7045138 <qt_meta_stringdata_KParts__ReadOnlyPart+408> "KParts::ReadOnlyPart", parentWidget=parentWidget@entry=0x555555793130, parent=parent@entry=0x555555793130, args=..., keyword=...) at /var/tmp/portage/kde-frameworks/kcoreaddons-5.44.0/work/kcoreaddons-5.44.0/src/lib/plugin/kpluginfactory.cpp:145
#24 0x000055555555ec22 in KPluginFactory::create<KParts::ReadOnlyPart> (args=..., parent=0x555555793130, this=0x555555a7b430) at /usr/include/KF5/KCoreAddons/kpluginfactory.h:513
#25 Akregator::MainWindow::loadPart (this=0x555555793130) at /var/tmp/portage/kde-apps/akregator-17.12.3/work/akregator-17.12.3/src/mainwindow.cpp:110
#26 0x000055555555d19a in Akregator::Application::activate (this=0x7fffffffd7d0, args=..., workingDir=...) at /var/tmp/portage/kde-apps/akregator-17.12.3/work/akregator-17.12.3/src/main.cpp:68
#27 0x00007ffff79c924d in KontactInterface::PimUniqueApplication::start (arguments=..., unique=<optimized out>) at /var/tmp/portage/kde-apps/kontactinterface-17.12.3/work/kontactinterface-17.12.3/src/pimuniqueapplication.cpp:135
#28 0x000055555555c9e2 in main (argc=<optimized out>, argv=<optimized out>) at /var/tmp/portage/kde-apps/akregator-17.12.3/work/akregator-17.12.3/src/main.cpp:106

Reported using DrKonqi
Comment 1 Christoph Feck 2018-04-27 01:10:03 UTC
Same crash.

*** This bug has been marked as a duplicate of bug 392478 ***