Bug 392498 - can't send a mail with an attachment
Summary: can't send a mail with an attachment
Status: RESOLVED NOT A BUG
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-29 18:07 UTC by Philippe ROUBACH
Modified: 2018-03-30 08:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
answer (deleted)
2018-03-29 21:14 UTC, Philippe ROUBACH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2018-03-29 18:07:32 UTC
kde apps 17.12.3
kde framework 5.44
plasma 5.12.4
kmail 5.7.3


one after updating to plasma 5.12.4
i send a mail with an attached file
then i get this:

This is the mail system at host smtp6-g21.free.fr.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<xxxxx@free.fr>: host mx1.free.fr[212.27.48.7] said: 550 spam detected (in
    reply to end of DATA command)
Comment 1 Philippe ROUBACH 2018-03-29 18:09:37 UTC
if i reply to a message with a message with an attachement then no problem.
Comment 2 Christophe Giboudeaux 2018-03-29 20:01:18 UTC
Well, that's Free's smtp server. Nothing that can be 'fixed' in KMail.

is it an empty HTML message with just an attachment ?
Comment 3 Philippe ROUBACH 2018-03-29 21:14:48 UTC
Created attachment 111727 [details]
answer

it is a message with a few words with an attachment
 i join the answer.
Comment 4 Philippe ROUBACH 2018-03-29 21:18:16 UTC
>> that's Free's smtp server

are you sure ?
because one or 2 months earlier there was also a problem with messages with attachment. laurent montel fixed it.
Comment 5 Philippe ROUBACH 2018-03-29 21:39:10 UTC
i found the report about similar problem in january
#388564
Comment 6 Christophe Giboudeaux 2018-03-29 22:39:33 UTC
Are you sure it's safe to have this mail attached to the bug report ? It contains personal information.

Anyway, I could test (same title, same content, attachment)

The message is sent without issue but the mailer daemon considers it's a spam if I send it from a free.fr address to another one.

I could send it from a free.fr address to my domain and from my domain to a free.fr address.

Really, that's a free.fr issue.
Comment 7 Ben Cooksley 2018-03-29 22:59:19 UTC
The content of attachment 111727 [details] has been deleted for the following reason:

Contains personal information
Comment 8 Philippe ROUBACH 2018-03-30 05:00:16 UTC
merci pour la pièce jointe.

here is a post at aduf forum
https://www.aduf.org/viewtopic.php?t=281819

Free team regularly reads posts. i hope this problem will be solved rapidly.
Comment 9 Christophe Giboudeaux 2018-03-30 08:17:44 UTC
Thanks.

I'm closing this BR. KMail delivered the message without issue.